<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html
xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head
profile="http://gmpg.org/xfn/11"><link
rel="stylesheet" type="text/css" href="http://jb.cdn.scaleengine.net/wp-content/cache/minify/000000/e7f88/default.include.e564b7.css" media="all" /><script type="text/javascript" src="http://jb2.cdn.scaleengine.net/wp-content/cache/minify/000000/e7f88/default.include.982d59.js"></script><meta
http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title>Skip grep, Use awk | BSD Now 201 | Jupiter Broadcasting</title><meta
name="viewport" content="width=device-width, initial-scale=1.0" /><link
rel="alternate" type="application/rss+xml" title="Jupiter Broadcasting RSS Feed" href="http://www.jupiterbroadcasting.com/feed/" /><link
rel="pingback" href="http://www.jupiterbroadcasting.com/xmlrpc.php" /><meta
property="og:image" content="http://jb6.cdn.scaleengine.net/wp-content/uploads/2017/07/bsd-0201-v.jpg"/><link
rel="image_src" href="http://jb6.cdn.scaleengine.net/wp-content/uploads/2017/07/bsd-0201-v.jpg"/><link
rel="shortcut icon" href="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/favicon.ico" type="image/x-icon"><link
rel="icon" href="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/favicon.ico" type="image/x-icon"><link
rel="author" href="https://plus.google.com/b/105226975130718072838/+JupiterBroadcasting/posts" /><meta
name="description" itemprop="description" content="We interview a unicorn, FreeNAS 11.0 is out, show you how to run Nextcloud in a FreeBSD jail & talk about the connection between oil changes & software patches." /><meta
name="keywords" itemprop="keywords" content="freebsd,openbsd,netbsd,dragonflybsd,trueos,tutorial,howto,guide,bsd,interview,bsd now,featured,video" /><link
rel="canonical" href="http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" /><script type="text/javascript">var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-1721760-1']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=true;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'.google-analytics.com/ga.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s);})();</script><script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.jupiterbroadcasting.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.9"}};!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link
rel='stylesheet' id='video-js-css-css'  href='//vjs.zencdn.net/4.12/video-js.css' type='text/css' media='all' /><link
rel='stylesheet' id='video-quality-selector-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/video-quality-selector.css' type='text/css' media='all' /><link
rel='stylesheet' id='ayvpp-style-css'  href='http://jb.cdn.scaleengine.net/wp-content/plugins//automatic-video-posts/css/style.css?ver=4.0' type='text/css' media='all' /><link
rel='stylesheet' id='bootstrap-css'  href='//netdna.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css' type='text/css' media='all' /><link
rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu:400,700' type='text/css' media='all' /><link
rel='stylesheet' id='font-awesome-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/bower_components/font-awesome/css/font-awesome.min.css?ver=2017042901' type='text/css' media='all' /><link
rel='stylesheet' id='default-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/style.css?ver=2017042901' type='text/css' media='all' /><script type='text/javascript' src='//code.jquery.com/jquery-3.1.0.min.js'></script><script type='text/javascript' src='//netdna.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js'></script><link
rel='https://api.w.org/' href='http://www.jupiterbroadcasting.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.jupiterbroadcasting.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.jupiterbroadcasting.com/wp-includes/wlwmanifest.xml" /><link
rel='prev' title='Low Road Journalism | Unfilter 243' href='http://www.jupiterbroadcasting.com/116381/low-road-journalism-unfilter-243/' /><meta
name="generator" content="WordPress 4.5.9" /><link
rel='shortlink' href='http://www.jupiterbroadcasting.com/?p=116401' /><link
rel="alternate" type="application/json+oembed" href="http://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.jupiterbroadcasting.com%2F116401%2Fskip-grep-use-awk-bsd-now-201%2F" /><link
rel="alternate" type="text/xml+oembed" href="http://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.jupiterbroadcasting.com%2F116401%2Fskip-grep-use-awk-bsd-now-201%2F&#038;format=xml" /> <script type="text/javascript">/*<![CDATA[*/function limitChars(textid,limit,infodiv)
{var text=jQuery('#'+textid).val();var textlength=text.length;if(textlength>limit)
{jQuery('#'+infodiv).html('You cannot write more then '+limit+' characters!');jQuery('#'+textid).val(text.substr(0,limit));return false;}
else
{jQuery('#'+infodiv).html('You have '+(limit-textlength)+' characters left.');return true;}}
function displayVals(){var t3=jQuery("#t3").val();var amount=jQuery("#amount").val();if(t3!=0){jQuery('#a3').val(amount);jQuery('#p3').val(1);jQuery('#cmd').val('_xclick-subscriptions')}else{jQuery('#a3').val(0);jQuery('#p3').val(0);jQuery('#cmd').val('_donations');}
if(!t3)jQuery('#cmd').val('_donations');}
jQuery(function(){jQuery('#donor_comment').keyup(function(){limitChars('donor_comment',199,'charinfo');})
jQuery("#amount").change(displayVals);jQuery("#t3").change(displayVals);displayVals();var WallOps1='<p class="show_onwall" id="wallops"><input type="hidden" name="item_number" value="0:0" /></p>';var WallOps2='<p class="show_onwall" id="wallops"><label for="show_onwall">Show on Wall:</label><br /><select name="item_number"><option value="1:0">Donation Amount, User Details &amp; Comments</option><option value="2:0" selected="selected">User Details &amp; Comments Only</option></select></p>';if(jQuery('#recognize').is(':checked')==false){jQuery('#wallinfo').hide();jQuery("#wallops").html(WallOps1);}
jQuery("#recognize").click(function(){jQuery("#wallinfo").toggle('slow');if(jQuery('#wallops input').val()=='0:0'){jQuery("#wallops").html(WallOps2);}else{jQuery("#wallops").html(WallOps1);}})});/*]]>*/</script><script>(function(){var t,i,e,n=window,o=document,a=arguments,s="script",r=["config","track","identify","visit","push","call"],c=function(){var t,i=this;for(i._e=[],t=0;r.length>t;t++)(function(t){i[t]=function(){return i._e.push([t].concat(Array.prototype.slice.call(arguments,0))),i}})(r[t])};for(n._w=n._w||{},t=0;a.length>t;t++)n._w[a[t]]=n[a[t]]=n[a[t]]||new c;i=o.createElement(s),i.async=1,i.src="//static.woopra.com/js/w.js",e=o.getElementsByTagName(s)[0],e.parentNode.insertBefore(i,e)})("woopra");woopra.config({"app":"wordpress","download_tracking":false,"outgoing_tracking":false,"hide_campaign":false});woopra.track();</script><link
rel="amphtml" href="http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/amp/" /></head><body
class="single single-post postid-116401 single-format-standard"><div
id="header"><div
id="logo" class='hidden-md hidden-lg'><div
class="wrapper"> <a
href="http://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img
src="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/images/logo.png" alt="Jupiter Broadcasting" /></a></div></div><div
class="container"><nav
class='navbar navbar-default' role="navigation"><div
class="navbar-header"> <button
type='button' class='navbar-toggle' data-toggle='collapse' data-target='#main-menu'> <span
class="sr-only">Toggle navigation</span> <span
class="icon-bar"></span> <span
class="icon-bar"></span> <span
class="icon-bar"></span> </button></div><div
id="main-menu" class="collapse navbar-collapse"><ul
id="menu-main-menu" class="nav navbar-nav"><li
id="menu-item-34721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-34721"><a
title="Home" href="http://www.jupiterbroadcasting.com">Home</a></li><li
id="menu-item-34726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34726 dropdown"><a
title="Shows" href="#" data-toggle="dropdown" class="dropdown-toggle">Shows <span
class="caret"></span></a><ul
role="menu" class=" dropdown-menu"><li
id="menu-item-113496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113496"><a
title="Ask Noah" href="http://www.jupiterbroadcasting.com/show/asknoah/">Ask Noah</a></li><li
id="menu-item-42722" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42722"><a
title="BSD Now" href="http://www.jupiterbroadcasting.com/show/bsdnow/">BSD Now</a></li><li
id="menu-item-34741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34741"><a
title="Coder Radio" href="http://www.jupiterbroadcasting.com/show/coderradio/">Coder Radio</a></li><li
id="menu-item-114676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114676"><a
title="Linux Action News" href="http://www.jupiterbroadcasting.com/show/linux-action-news/">Linux Action News</a></li><li
id="menu-item-41942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41942"><a
title="LINUX Unplugged" href="http://www.jupiterbroadcasting.com/show/linuxun/">LINUX Unplugged</a></li><li
id="menu-item-34781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34781"><a
title="TechSNAP" href="http://www.jupiterbroadcasting.com/show/techsnap/">TechSNAP</a></li><li
id="menu-item-34786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34786"><a
title="Unfilter" href="http://www.jupiterbroadcasting.com/show/unfilter/">Unfilter</a></li><li
id="menu-item-88001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88001"><a
title="Rover Log" href="http://www.jupiterbroadcasting.com/show/rover-log/">Rover Log</a></li><li
id="menu-item-102376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102376"><a
title="User Error" href="http://www.jupiterbroadcasting.com/show/error/">User Error</a></li></ul></li><li
id="menu-item-34796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34796"><a
title="LIVE!" href="http://www.jupiterbroadcasting.com/watch-us-live/">LIVE!</a></li><li
id="menu-item-34801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34801"><a
title="Calendar" href="http://www.jupiterbroadcasting.com/release-calendar/">Calendar</a></li><li
id="menu-item-115491" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115491"><a
title="Hosts" href="/hosts/">Hosts</a></li><li
id="menu-item-49972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49972 dropdown"><a
title="Archive" href="#" data-toggle="dropdown" class="dropdown-toggle">Archive <span
class="caret"></span></a><ul
role="menu" class=" dropdown-menu"><li
id="menu-item-49982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49982"><a
title="Beer is Tasty" href="http://www.jupiterbroadcasting.com/show/beeristasty/">Beer is Tasty</a></li><li
id="menu-item-49997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49997"><a
title="Computer Action Show" href="http://www.jupiterbroadcasting.com/show/cas/">Computer Action Show</a></li><li
id="menu-item-34746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34746"><a
title="FauxShow" href="http://www.jupiterbroadcasting.com/show/fauxshow/">FauxShow</a></li><li
id="menu-item-59332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332"><a
title="HowTo Linux" href="http://www.jupiterbroadcasting.com/show/h2l/">HowTo Linux</a></li><li
id="menu-item-50007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50007"><a
title="IN DEPTH LOOK" href="http://www.jupiterbroadcasting.com/show/indepthlook/">IN DEPTH LOOK</a></li><li
id="menu-item-50037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50037"><a
title="Joint Failures" href="http://www.jupiterbroadcasting.com/show/jointfailures/">Joint Failures</a></li><li
id="menu-item-50012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50012"><a
title="Jupiter@Nite" href="http://www.jupiterbroadcasting.com/show/nite/">Jupiter@Nite</a></li><li
id="menu-item-50042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50042"><a
title="Legend of the Stoned Owl" href="http://www.jupiterbroadcasting.com/show/legend-of-the-stoned-owl/">Legend of the Stoned Owl</a></li><li
id="menu-item-34766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34766"><a
title="Linux Action Show" href="http://www.jupiterbroadcasting.com/show/linuxactionshow/">Linux Action Show</a></li><li
id="menu-item-50017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50017"><a
title="MMOrgue" href="http://www.jupiterbroadcasting.com/show/mmorgue/">MMOrgue</a></li><li
id="menu-item-35751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35751"><a
title="Plan B" href="http://www.jupiterbroadcasting.com/show/planb/">Plan B</a></li><li
id="menu-item-34771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34771"><a
title="SciByte" href="http://www.jupiterbroadcasting.com/show/scibyte/">SciByte</a></li><li
id="menu-item-50022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50022"><a
title="STOked" href="http://www.jupiterbroadcasting.com/show/stoked/">STOked</a></li><li
id="menu-item-58772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58772"><a
title="Tech Talk Today" href="http://www.jupiterbroadcasting.com/show/today/">Tech Talk Today</a></li><li
id="menu-item-50027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50027"><a
title="TORked" href="http://www.jupiterbroadcasting.com/show/torked/">TORked</a></li><li
id="menu-item-71892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71892"><a
title="Women&#039;s Tech Radio" href="http://www.jupiterbroadcasting.com/show/wtr/">Women&#8217;s Tech Radio</a></li></ul></li><li
id="menu-item-34806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34806"><a
title="Contact" href="http://www.jupiterbroadcasting.com/contact/">Contact</a></li><li
id="menu-item-34811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34811"><a
title="Advertising" href="http://www.jupiterbroadcasting.com/advertising/">Advertising</a></li><li
id="menu-item-48917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48917"><a
title="Forum" href="http://jupitercolony.com/">Forum</a></li><li
id="menu-item-34826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34826"><a
title="Donate" href="http://www.jupiterbroadcasting.com/support-us/">Donate</a></li></ul></div><form
method="get" id="searchForm" action="http://www.jupiterbroadcasting.com/" class='navbar-form navbar-right hidden-sm'> <input
placeholder="Search..." name="s" id="s" value="" /> <input
id="searchsubmit" type="image" src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/search.png" alt="Submit" /></form></nav></div></div><div
id="thevideo"><div
id="thevideoinside"><div
id="videoembed" class='container'><div
class='video responsive-object-wrapper vjs4'> <video
id="video" class="video-js vjs-default-skin vjs-big-play-centered" controls preload="none" width="854" height="506" poster="http://jb6.cdn.scaleengine.net/wp-content/uploads/2017/07/bsd-0201-v.jpg" data-setup='{ "plugins" : { "resolutionSelector" : { "default_res" : "SD" } } }' > <source
src="http://www.podtrac.com/pts/redirect.mp4/201406.jb-dl.cdn.scaleengine.net/bsdnow/2017/bsd-0201.mp4" type="video/mp4" data-res="HD" /><p
class="vjs-no-js">To view this video please enable JavaScript, and consider upgrading to a web browser that <a
href="http://videojs.com/html5-video-support/" target="_blank">supports HTML5 video</a></p> </video></div></div></div></div><div
id="content" class='container'><div
class='row'><div
id="contentleft" class='col-md-8 col-lg-9'><div
id=""><div
id="videodets" class='clearfix'><div
id="postinfo"><h2><a
href="http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" title="Skip grep, use awk | BSD Now 201">Skip grep, use awk | BSD Now 201</a></h2><p
class="itemlinks"></p><p
class="itemlinks">Posted on: <a
href="http://www.jupiterbroadcasting.com/date/2017/07/06/">July 6, 2017</a></p><p
class="itemlinks">Posted in: <a
href="http://www.jupiterbroadcasting.com/show/bsdnow/" rel="category tag">BSD Now</a>, <a
href="http://www.jupiterbroadcasting.com/show/featured/" rel="category tag">Featured</a>, <a
href="http://www.jupiterbroadcasting.com/show/video/" rel="category tag">Video</a></p><p
class="itemlinks"><a
href="#comments" title="Comment on This Video">Comment on This Video</a></p><p
class="itemlinks"><a
href="javascript:;" onmousedown="toggleSlide('sharearea');" title="Share this episode with others">Share This Video</a></p><div
id="sharearea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0; "><div
id="socialize"><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/delicious.gif" alt="del" /> <a
href="http://del.icio.us/post?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">del.icio.us</a></li><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/blinklist.gif" alt="blink" /> <a
href="http://blinklist.com/index.php?Action=Blink/addblink.php&Url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">blinklist</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/digg.gif" alt="digg" /> <a
href="http://digg.com/submit?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">digg</a></li><li><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/facebook.gif" alt="face" /> <a
href="http://www.facebook.com/share.php?u=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Facebook</a></li></ul></div><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/furl.gif" alt="furl" /> <a
href="http://furl.net/storeIt.jsp?u=&t=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Furl</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/magnolia.gif" alt="magnol" /> <a
href="http://ma.gnolia.com/bookmarklet/add?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">ma.gnolia</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/newsvine.gif" alt="newsv" /> <a
href="http://www.newsvine.com/_wine/save?u=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Newsvine</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/pownce.gif" alt="pownce" /> <a
href="http://pownce.com/send/link/?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Pownce</a></li></ul></div><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/reddit.gif" alt="reddit" /> <a
href="http://reddit.com/submit?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">reddit</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/stumbleupon.gif" alt="stumble" /> <a
href="http://www.stumbleupon.com/submit?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">StumbleUpon</a></li><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/technorati.gif" alt="tech" /> <a
href="http://www.technorati.com/faves?add=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Technorati</a></li><li><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/twitter.gif" alt="twit" /> <a
href="http://twitthis.com/twit?url=http://www.jupiterbroadcasting.com/116401/skip-grep-use-awk-bsd-now-201/" target="_blank">Twitter</a></li></ul></div></div></div><p
class="itemlinks"><a
href="javascript:;" onmousedown="toggleSlide('embedarea');" title="Embed episode on your website">Embed This Video</a></p><div
id="embedarea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0;"><textarea name="thoughts" rows=4 style="border:1px solid #B8B8B8; width:642px; background:none; padding:5px; color:#565050; font-family:Arial, Helvetica, sans-serif; font-size: 12px; margin-top: 10px; overflow: hidden;"></textarea></div></div><div
class="thumbnail"> <img
width="300" height="178" src="http://jb5.cdn.scaleengine.net/wp-content/uploads/2017/07/bsd-0201-v-300x178.jpg" class="attachment-medium size-medium wp-post-image" alt="bsd-0201-v" srcset="http://jb7.cdn.scaleengine.net/wp-content/uploads/2017/07/bsd-0201-v-300x178.jpg 300w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/07/bsd-0201-v-200x120.jpg 200w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/07/bsd-0201-v-768x455.jpg 768w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/07/bsd-0201-v.jpg 854w" sizes="(max-width: 300px) 100vw, 300px" /></div></div><div
id="synopsis"><p>We interview a unicorn, FreeNAS 11.0 is out, show you how to run Nextcloud in a FreeBSD jail &#038; talk about the connection between oil changes and software patches.</p></div><div
id="sponsors"><p><strong>Thanks to:</strong></p><p><a
href="https://www.digitalocean.com/?utm_source=BSDNow&amp;utm_medium=Podcast&amp;utm_campaign=BSD+Now+Podcast" target="_blank"><br
/> <img
src="http://jb5.cdn.scaleengine.net/wp-content/uploads/2015/01/do-bsd-freebsdnow.jpg" alt="DigitalOcean" height="70" border="0" /></a></p><ul><li><a
href="https://www.digitalocean.com/community/get-paid-to-write">Get Paid to Write for DigitalOcean</a></li></ul><p><a
href="http://www.ixsystems.com/bsdnow/" target="_blank"><br
/> <img
src="http://jb6.cdn.scaleengine.net/wp-content/uploads/2015/07/iXsystems-Banner-bsd-2015.jpg" alt="iXsystems" height="70" border="0" /></a><br
/> <a
href="http://www.tarsnap.com/bsdnow" target="_blank"><br
/> <img
src="http://jb6.cdn.scaleengine.net/wp-content/uploads/2014/05/Tarsnap-bsd-banner.jpg" alt="Tarsnap" height="70" border="0" /></a></p></div><div
id="direct-downloads"><h3>Direct Download:</h3><ul><li><a
href="http://www.podtrac.com/pts/redirect.mp4/201406.jb-dl.cdn.scaleengine.net/bsdnow/2017/bsd-0201.mp4">HD Video</a></li><li><a
href="http://www.podtrac.com/pts/redirect.mp3/traffic.libsyn.com/jnite/bsd-0201.mp3">MP3 Audio</a></li><li><a
href="http://bitlove.org/jupiterbroadcasting/bsdnowhd">Torrent</a></li><li><a
href="https://www.youtube.com/watch?v=iCyr-RSmjq4">YouTube</a></li></ul></div><div
id="postcontent"><h3>RSS Feeds:</h3><p><a
href="http://feeds.feedburner.com/BsdNowMp3">MP3 Feed</a> <strong>|</strong> <a
href="https://itunes.apple.com/us/podcast/bsd-now-mp3/id701045710?mt=2">iTunes Feed</a> <strong>|</strong> <a
href="http://feeds.feedburner.com/BsdNowHd">HD Vid Feed</a> <strong>|</strong> <a
href="http://bitlove.org/jupiterbroadcasting/bsdnowhd/feed">HD Torrent Feed</a></p><h3><a
href="http://www.patreon.com/jupitersignal">Become a supporter on Patreon</a>:</h3><p><a
href="http://www.patreon.com/jupitersignal" rel="Support us on Patreon"><img
src="http://i.imgur.com/2ioAf3Q.png" alt="Patreon" /></a></p><h3>&#8211; Show Notes: &#8211;</h3><h2>Headlines</h2><h3><a
href="http://www.freenas.org/blog/freenas-11-0/">FreeNAS 11.0 is Now Here</a></h3><ul><li>The FreeNAS blog informs us:</li></ul><blockquote><p>After several FreeNAS Release Candidates, FreeNAS 11.0 was released today. This version brings new virtualization and object storage features to the World’s Most Popular Open Source Storage Operating System. FreeNAS 11.0 adds bhyve virtual machines to its popular SAN/NAS, jails, and plugins, letting you use host web-scale VMs on your FreeNAS box. It also gives users S3-compatible object storage services, which turns your FreeNAS box into an S3-compatible server, letting you avoid reliance on the cloud.<br
/> FreeNAS 11.0 also introduces the beta version of a new administration GUI. The new GUI is based on the popular Angular framework and the FreeNAS team expects the GUI to be themeable and feature complete by 11.1. The new GUI follows the same flow as the existing GUI, but looks better. For now, the FreeNAS team has released it in beta form to get input from the FreeNAS community. The new GUI, as well as the classic GUI, are selectable from the login screen.<br
/> Also new in FreeNAS 11 is an Alert Service page which configures the system to send critical alerts from FreeNAS to other applications and services such as Slack, PagerDuty, AWS, Hipchat, InfluxDB, Mattermost, OpsGenie, and VictorOps. FreeNAS 11.0 has an improved Services menu that adds the ability to manage which services and applications are started at boot.<br
/> The FreeNAS community is large and vibrant. We invite you to join us on the <a
href="https://forums.freenas.org/index.php">FreeNAS forum</a> and the #freenas IRC channel on Freenode. To download FreeNAS and sign-up for the FreeNAS Newsletter, visit <a
href="http://www.freenas.org/download/">freenas.org/download</a>.</p></blockquote><hr
/><h3><a
href="https://www.exoscale.ch/syslog/2017/06/26/building-an-ipsec-gateway-with-openbsd/">Building an IPsec Gateway With OpenBSD</a></h3><ul><li>Pierre-Yves Ritschard wrote the following blog article:</li></ul><blockquote><p>With private networks just released on Exoscale, there are now more options to implement secure access to Exoscale cloud infrastructure. While we still recommend the bastion approach, as detailed in <a
href="https://www.exoscale.ch/syslog/2016/01/15/secure-your-cloud-computing-architecture-with-a-bastion/">this article</a>, there are applications or systems which do not lend themselves well to working this way.<br
/> In these cases, the next best thing is building IPsec gateways. IPsec is a protocol which works directly at layer 3. It uses its configuration to determine which network flows should be sent encrypted on the wire. Once IPsec is correctly configured, selected network flows are transparently encrypted and applications do not need to modify anything to benefit from secured traffic.</p></blockquote><ul><li>In addition to encryption, IPSec also authenticates the end points, so you can be sure you are exchanging packets with a trusted host</li></ul><blockquote><p>For the purposes of this article we will work under the following assumptions: We want a host to network setup, providing access to cloud-hosted infrastructure from a desktop environment.<br
/> Only stock tooling should be used on desktop environment, no additional VPN client should be needed.<br
/> In this case, to ensure no additional software is needed on the client, we will configure an L2TP/IPsec gateway. This article will use OpenBSD as the operating system to implement the gateway. While this choice may sound surprising, OpenBSD excels at building gateways of all sorts thanks to its simple configuration formats and inclusion of all necessary software and documentation to do so in the base system.</p></blockquote><ul><li>The tutorial assumes you have setup a local network between the hosts in the cloud, and walks through the configuration of an OpenBSD host as a IPsec gateway</li></ul><blockquote><p>On the OpenBSD host, all necessary software is already installed. We will configure the system, as well as pf, npppd, and ipsec</p><ul><li>Configure L2TP</li><li>Configure IPsec</li><li>Configure NAT</li><li> Enabled services: ipsec isakmpd npppd</li></ul></blockquote><ul><li>The tutorial then walks through configuring a OS X client, but other desktops will be very similar</li></ul><hr
/><h3><a
href="https://ramsdenj.com/2017/06/05/nextcloud-in-a-jail-on-freebsd.html">Running Nextcloud in a jail on FreeBSD</a></h3><blockquote><p>I recently setup Nextcloud 12 inside a FreeBSD jail in order to allow me access to files i might need while at University. I figured this would be a optimal solution for files that I might need access to unexpectedly, on computers where I am not in complete control. My Nextcloud instance is externally accessible, and yet if someone were to get inside my Jail, I could rest easy knowing they still didn’t have access to the rest of my host server. I chronicled the setup process including jail setup using iocage, https with Lets Encrypt, and full setup of the web stack.<br
/> Nextcloud has a variety of features such as calendar synchronization, email, collaborative editing, and even video conferencing. I haven’t had time to play with all these different offerings and have only utilized the file synchronization, but even if file sync is not needed, Nextcloud has many offerings that make it worth setting up.</p></blockquote><ul><li>MariaDB, PHP 7.0, and Apache 2.4</li></ul><blockquote><p>To manage my jails I’m using iocage. In terms of jail managers it’s a fairly new player in the game of jail management and is being very actively developed. It just had a full rewrite in Python, and while the code in the background might be different, the actual user interface has stayed the same.<br
/> Iocage makes use of ZFS clones in order to create “base jails”, which allow for sharing of one set of system packages between multiple jails, reducing the amount of resources necessary. Alternatively, jails can be completely independent from each other; however, using a base jail makes it easier to update multiple jails as well.</p><ul><li>pkg install iocage</li><li>sysrc iocage_enable=YES</li><li>iocage fetch -r 11.0-RELEASE</li><li>iocage create tag=&#8221;stratus&#8221; jail_zfs=on vnet=off boot=on ip4_addr=&#8221;sge0|172.20.0.100/32&#8243; -r 11.0-RELEASE</li><li>iocage start stratus</li><li>iocage console stratus</li></ul><p>I have chosen to provide storage to the Nextcloud Jail by mounting a dataset over NFS on my host box. This means my server can focus on serving Nextcloud and my storage box can focus on housing the data. The Nextcloud Jail is not even aware of this since the NFS Mount is simply mounted by the host server into the jail. The other benefit of this is the Nextcloud jail doesn’t need to be able to see my storage server, nor the ability to mount the NFS share itself.<br
/> Using a separate server for storage isn’t necessary and if the storage for my Nextcloud server was being stored on the same server I would have created a ZFS dataset on the host and mounted it into the jail.<br
/> Next I set up a dataset for the database and delegated it into the jail. Using a separate dataset allows me to specify certain properties that are better for a database, it also makes migration easier in case I ever need to move or backup the database.<br
/> With most of the requirements in place it was time to start setting up Nextcloud. The requirements for Nextcloud include your basic web stack of a web server, database, and PHP.</p></blockquote><ul><li>Also covers the setup of acme.sh for LetsEncrypt. This is now available as a package, and doesn’t need to be manually fetched</li><li>Install a few more packages, and do a bit of configuration, and you have a NextCloud server</li></ul><hr
/><h3><a
href="http://bad.network/historical-my-first-openbsd-hackathon.html">Historical: My first OpenBSD Hackathon</a></h3><ul><li>This is a blog post by our friend, and OpenBSD developer: Peter Hessler</li></ul><blockquote><p>This is a story about encouragement. Every time I use the word &#8220;I&#8221;, you should think &#8220;I as in me, not I as in the author&#8221;.<br
/> In 2003, I was invited to my first OpenBSD Hackathon. Way before I was into networking, I was porting software to my favourite OS. Specifically, I was porting games.<br
/> On the first night most of the hackathon attendees end up at the bar for food and beer, and I&#8217;m sitting next to Theo de Raadt, the founder of OpenBSD. At some point during the evening, he&#8217;s telling me about all of these &#8220;crazy&#8221; ideas he has about randomizing libraries, and protections that can be done in ld.so. (ld.so is the part of the OS that loads the libraries your program needs. It&#8217;s, uh, kinda important.) Theo is encouraging me to help implement some of these ideas! At some point I tell Theo &#8220;I&#8217;m just a porter, I don&#8217;t know C.&#8221;<br
/> Theo responds with &#8220;It isn&#8217;t hard, I&#8217;ll have Dale (Rahn) show you how ld.so works, and you can do it.&#8221; I was hoping that all of this would be forgotten by the next day, but sure enough Dale comes by. &#8220;Hey, are you Peter? Theo wanted me to show you how ld.so works&#8221; Dale spends an hour or two showing me how it works, the code structure, and how to recover in case of failure.<br
/> At first I had lots of failures. Then more failures. And even more failures. Once, I broke my machine so badly I had to reinstall it. I learned a lot about how an OS works during this. But, I eventually started doing changes without it breaking. And some even did what I wanted! By the end of the hackathon I had came up with a useful patch, that was committed as part of a larger change.<br
/> I was a nobody. With some encouragement, enough liquid courage to override my imposter syndrome, and a few hours of mentoring, I&#8217;m now doing big projects. The next time you&#8217;re sitting at a table with someone new to your field, ask yourself: how can you encourage them? You just might make the world better.<br
/> Thank you Dale. And thank you Theo.</p></blockquote><ul><li>Everyone has to start somewhere.</li><li>One of the things that sets the BSDs apart from certain other open source operating systems, is the welcoming community, and the tradition of mentorship.</li><li>Sure, someone else in the OpenBSD project could have done the bits that Peter did, likely a lot more quickly, but then OpenBSD wouldn’t have gained a new committer.</li><li>So, if you are interested in working on one of the BSDs, reach out, and we’ll try to help you find a mentor.</li><li>What part of the system do you want to work on?</li></ul><hr
/><h4>Interview &#8211; Dan McDonald &#8211; <a
href="mailto:allcoms@gmail.com">allcoms@gmail.com</a> (danboid)</h4><hr
/><h2>News Roundup</h2><h3><a
href="https://lists.freebsd.org/pipermail/freebsd-stable/2017-July/087340.html">FreeBSD 11.1-RC1 Available</a></h3><ul><li>11.1-RC1 Installation images are available for:<ul><li>amd64, i386</li><li>powerpc, powerpc64</li><li>sparc64</li><li>armv6 BANANAPI, BEAGLEBONE, CUBIEBOARD, CUBIEBOARD2, CUBOX-HUMMINGBOARD, GUMSTIX, RPI-B, RPI2, PANDABOARD, WANDBOARD</li><li>aarch64 (aka arm64), including the RPI3, Pine64, OverDrive 1000, and Cavium Server</li></ul></li><li>A summary of changes since BETA3 includes:<ul><li>Several build toolchain related fixes.</li><li>A use-after-free in RPC client code has been corrected.</li><li>The ntpd(8) leap-seconds file has been updated.</li><li>Various VM subsystem fixes.</li><li>The &#8216;_&#8217; character is now allowed in newfs(8) labels.</li><li>A potential sleep while holding a mutex has been corrected in the sa(4) driver.</li><li>A memory leak in an ioctl handler has been fixed in the ses(4) driver.</li></ul></li><li>Virtual Machine Disk Images are available for the amd64 and i386 architectures.</li><li><p>Amazon EC2 AMI Images of FreeBSD/amd64 EC2 AMIs are available</p><ul><li>The freebsd-update(8) utility supports binary upgrades of amd64 and i386 systems running earlier FreeBSD releases.  Systems running earlier FreeBSD releases can upgrade as follows:</li></ul><blockquote><p>freebsd-update upgrade -r 11.1-RC1</p></blockquote><ul><li>During this process, freebsd-update(8) may ask the user to help by merging some configuration files or by confirming that the automatically performed merging was done correctly.</li></ul><blockquote><p>freebsd-update install</p></blockquote><ul><li>The system must be rebooted with the newly installed kernel before continuing.</li></ul><blockquote><p>shutdown -r now</p></blockquote><ul><li>After rebooting, freebsd-update needs to be run again to install the new userland components:</li></ul><blockquote><p>freebsd-update install</p></blockquote><ul><li>It is recommended to rebuild and install all applications if possible, especially if upgrading from an earlier FreeBSD release, for example, FreeBSD 10.x.  Alternatively, the user can install misc/compat10x and other compatibility libraries, afterwards the system must be rebooted into the new userland:</li></ul><blockquote><p>shutdown -r now</p></blockquote><ul><li>Finally, after rebooting, freebsd-update needs to be run again to remove stale files:</li></ul><blockquote><p>freebsd-update install</p></blockquote></li></ul><hr
/><h3><a
href="http://www.daemonology.net/blog/2017-06-14-oil-changes-safety-recalls-software-patches.html">Oil changes, safety recalls, and software patches</a></h3><blockquote><p>Every few months I get an email from my local mechanic reminding me that it&#8217;s time to get my car&#8217;s oil changed. I generally ignore these emails; it costs time and money to get this done (I&#8217;m sure I could do it myself, but the time it would cost is worth more than the money it would save) and I drive little enough — about 2000 km/year — that I&#8217;m not too worried about the consequences of going for a bit longer than nominally advised between oil changes. I do get oil changes done&#8230; but typically once every 8-12 months, rather than the recommended 4-6 months. From what I&#8217;ve seen, I don&#8217;t think I&#8217;m alone in taking a somewhat lackadaisical approach to routine oil changes.<br
/> On the other hand, there&#8217;s another type of notification which elicits more prompt attention: Safety recalls. There are two good reasons for this: First, whether for vehicles, food, or other products, the risk of ignoring a safety recall is not merely that the product will break, but rather that the product will be actively unsafe; and second, when there&#8217;s a safety recall you don&#8217;t have to pay for the replacement or fix — the cost is covered by the manufacturer.<br
/> I started thinking about this distinction — and more specifically the difference in user behaviour — in the aftermath of the &#8220;WannaCry&#8221; malware. While WannaCry attracted widespread attention for its &#8220;ransomware&#8221; nature, the more concerning aspect of this incident is how it propagated: By exploiting a vulnerability in SMB for which Microsoft issued patches two months earlier. As someone who works in computer security, I find this horrifying — and I was particularly concerned when I heard that the NHS was postponing surgeries because they couldn&#8217;t access patient records. Think about it: If the NHS couldn&#8217;t access patient records due to WannaCry, it suggests WannaCry infiltrated systems used to access patient records — meaning that someone else exploiting the same vulnerabilities could have accessed those records. The SMB subsystem in Windows was not merely broken; until patches were applied, it was actively unsafe.<br
/> I imagine that most people in my industry would agree that security patches should be treated in the same vein as safety recalls — unless you&#8217;re certain that you&#8217;re not affected, take care of them as a matter of urgency — but it seems that far more users instead treat security patches more like oil changes: something to be taken care of when convenient&#8230; or not at all, if not convenient. It&#8217;s easy to say that such users are wrong; but as an industry it&#8217;s time that we think about why they are wrong rather than merely blaming them for their problems.<br
/> There are a few factors which I think are major contributors to this problem. First, the number of updates: When critical patches occur frequently enough to become routine, alarm fatigue sets in and people cease to give the attention updates deserve, even if on a conscious level they still recognize the importance of applying updates.</p></blockquote><ul><li>Colin also talks about his time as the FreeBSD Security Officer, and the problems in ensuring the patches are correct and do not break the system when installed</li><li>He also points out the problem of systems like Windows Update, the combines optional updates, and things like its license checking tool, in the same interface that delivers important updates. Or my recent machines, that gets constant popups about how some security updates will not be delivered because my processor is too new.</li></ul><blockquote><p>My bank sends me special offers in the mail but phones if my credit card usage trips fraud alarms; this is the sort of distinction in intrusiveness we should see for different types of software updates<br
/> Finally, I think there is a problem with the mental model most people have of computer security. Movies portray attackers as geniuses who can break into any system in minutes; journalists routinely warn people that &#8220;nobody is safe&#8221;; and insurance companies offer insurance against &#8220;cyberattacks&#8221; in much the same way as they offer insurance against tornados. Faced with this wall of misinformation, it&#8217;s not surprising that people get confused between 400 pound hackers sitting on beds and actual advanced persistent threats. Yes, if the NSA wants to break into your computer, they can probably do it — but most attackers are not the NSA, just like most burglars are not Ethan Hunt. You lock your front door, not because you think it will protect you from the most determined thieves, but because it&#8217;s an easy step which dramatically reduces your risk from opportunistic attack; but users don&#8217;t see applying security updates as the equivalent of locking their front door when they leave home.</p></blockquote><hr
/><h3><a
href="http://blog.jpalardy.com/posts/skip-grep-use-awk/">SKIP grep, use AWK</a></h3><ul><li>This is a tip from Jonathan Palardy in a series of blog posts about awk. It is especially helpful for people who write a lot of shell scripts or are using a lot of pipes with awk and grep.</li></ul><blockquote><p>Over the years, I’ve seen many people use this pattern (filter-map):</p><blockquote><p>$ [data is generated] | grep something | awk &#8216;{print $2}&#8217;</p></blockquote><p>but it can be shortened to:</p><blockquote><p>$ [data is generated] | awk &#8216;/something/ {print $2}&#8217;</p></blockquote></blockquote><ul><li>AWK can take a regular expression (the part between the slashes) and matches that to the input. Anything that matches is being passed to the print $2 action (to print the second column).</li></ul><blockquote><p>Why would I do this?</p><p>I can think of 4 reasons:</p><blockquote><ul><li>it’s shorter to type</li><li>it spawns one less process</li><li>awk uses modern (read “Perl”) regular expressions, by default – like grep -E</li><li>it’s ready to “augment” with more awk</li></ul></blockquote></blockquote><ul><li>How about matching the inverse (search for patterns that do NOT match)?</li></ul><blockquote><p>But “grep -v” is OK…<br
/> Many people have pointed out that “grep -v” can be done more concisely with:</p><blockquote><p>$ [data is generated] | awk &#8216;! /something/&#8217;</p></blockquote></blockquote><ul><li>See if you have such combinations of grep piped to awk and fix those in your shell scripts. It saves you one process and makes your scripts much more readable. Also, check out the other intro links on the blog if you are new to awk.</li></ul><hr
/><h3><a
href="https://vim-adventures.com">vim Adventures</a></h3><ul><li>This website, created by Doron Linder, will playfully teach you how to use vim.</li><li>Hit any key to get started and follow the instructions on the playing field by moving the cursor around.</li><li>There is also a menu in the bottom left corner to save your game.</li><li>Try it out, increase your vim-fu, and learn how to use a powerful text editor more efficiently.</li></ul><hr
/><h2>Beastie Bits</h2><ul><li><a
href="http://pkgsrc.org/pkgsrcCon/2017/talks.html">Slides from PkgSrcCon</a></li><li><a
href="http://marc.info/?l=openbsd-tech&amp;m=149902196520920&amp;w=2">OpenBSD’s doas adds systemd compat shim</a></li><li><a
href="https://deadlockempire.github.io/">Deadlock Empire &#8212; “Each challenge below is a computer program of two or more threads. You take the role of the Scheduler &#8211; and a cunning one! Your objective is to exploit flaws in the programs to make them crash or otherwise malfunction.”</a></li><li><a
href="https://www.freebsdfoundation.org/blog/eurobsdcon-2017-travel-grant-application-now-open/">EuroBSDcon 2017 Travel Grant Application Now Open</a></li><li><a
href="http://www.vbsdcon.com/">Registration for vBSDCon is open </a> &#8211; Registration is only $100 if you register before July 31. Discount hotel rooms arranged at the Hyatt for only $100/night while supplies last.</li><li><a
href="https://bsdtw.org/">BSD Taiwan call for papers opens, closes July 31st</a>Windows Application Versand</li></ul><hr
/><h2>Feedback/Questions</h2><ul><li><a
href="http://dpaste.com/2AM6C2H#wrap">Joseph &#8211; Server Monitoring</a></li><li><a
href="http://dpaste.com/1Z4FBE2#wrap">Paulo &#8211; Updating Jails</a></li><li><a
href="http://dpaste.com/2MNM9GJ#wrap">Kevin &#8211; openvpn server</a></li><li><a
href="http://dpaste.com/17BVBJ3#wrap">Todd &#8211; several questions</a></li></ul><hr
/><ul><li>Send questions, comments, show ideas/topics, or stories you want mentioned on the show to <a
href="mailto:feedback@bsdnow.tv">feedback@bsdnow.tv</a></li></ul><hr
/></div><h3>Question? Comments? <a
href="/contact">Contact us here!</a></h3></div></div><div
id="contentright" class='col-md-4 col-lg-3'><div
id="sidebar"><div
id="logo" class='visible-md visible-lg'> <a
href="http://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img
src="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/images/logo.png" alt="Jupiter Broadcasting" /></a></div><div
class="widget"><h3 class='widget-title'>Related Posts</h3><div
class="widget-body" id="ratingsblock"><ul><li><a
href="http://www.jupiterbroadcasting.com/113981/tales-of-filesystems-techsnap-315/" rel="bookmark" title="April 18, 2017">Tales of FileSystems | TechSNAP 315</a></li><li><a
href="http://www.jupiterbroadcasting.com/44887/go-directly-to-jail8-bsd-now-7/" rel="bookmark" title="October 18, 2013">Go Directly to Jail(8) | BSD Now 7</a></li><li><a
href="http://www.jupiterbroadcasting.com/107556/exit-interview-bsd-now-185/" rel="bookmark" title="March 16, 2017">Exit Interview | BSD Now 185</a></li><li><a
href="http://www.jupiterbroadcasting.com/98861/freenas-mini-xl-bsd-now-137/" rel="bookmark" title="April 14, 2016">FreeNAS Mini XL | BSD Now 137</a></li><li><a
href="http://www.jupiterbroadcasting.com/49707/bhyve-mind-bsd-now-20/" rel="bookmark" title="January 16, 2014">Bhyve Mind | BSD Now 20</a></li></ul></div></div><div
class="widget"><h3 class="widget-title">Show Feeds and Social Networks</h3><div
class="widget-body"><div
id="social-widget"><ul
class='inline icons'><li> <a
target="_blank" href="http://ax.search.itunes.apple.com/WebObjects/MZSearch.woa/wa/search?entity=podcast&media=all&page=1&restrict=true&startIndex=0&term=Jupiter+Broadcasting" title="Subscribe in iTunes"> <img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-itunes.svg"/> </a></li><li> <a
target="_blank" href="https://plus.google.com/105226975130718072838" title="Circle us on Google+"> <img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-google-plus.svg" /> </a></li><li> <a
target="_blank" href="http://www.facebook.com/pages/Jupiter-Broadcasting/156241429615" title="Join our Facebook Page"> <img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-facebook.svg" /> </a></li><li> <a
target="_blank" href="https://twitter.com/jupitersignal" title="Follow us on Twitter"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-twitter.svg"/> </a></li><li> <a
target="_blank" href="http://bit.ly/jbsubreddits" title="Contribute on Reddit"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-reddit.svg"/> </a></li><li> <a
target="_blank" href="https://instagram.com/jupiterbroadcasting/" title="Follow us on Instragram"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-instagram.svg"/> </a></li><li> <a
target="_blank" href="https://www.youtube.com/user/jupiterbroadcasting" title="Subscribe on Youtube"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-youtube.svg"/> </a></li></ul><script type="text/javascript">/*<![CDATA[*/function go(e){var destination=e.options[e.selectedIndex].value;if(destination&&destination!=0)window.open(destination,'_blank');}/*]]>*/</script><div
class="rss-container"> <img
class="rss-icon" src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-rss.png"><h3>Subscribe via RSS:</h3> <select
onchange="go(this);"><option
value="0" selected="selected">Subscribe...</option><option
value="0">-- ALL SHOWS --</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=286971585">iTunes Large Video</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=280019325">iTunes MP3</option><option
value="http://feeds2.feedburner.com/AllJupiterVideos">Large Video RSS</option><option
value="http://feeds2.feedburner.com/JupiterBroadcasting">MP3 Audio RSS</option><option
value="0"></option><option
value="0">-- PODCAST NETWORKS --</option><option
value="http://landing.stitcher.com/?srcid=515">Stitcher</option><option
value="http://subscribe.getmiro.com/?url1=http%3A//feeds2.feedburner.com/JupiterBroadcastingVideos&trackback1=http%3A//www.miroguide.com/feeds/9506/subscribe-hit&section1=video">Miro</option><option
value="http://social.zune.net/redirect?type=podcastseries&id=66a6dec9-5ff2-45c6-99cd-0d74d4d02f5e&target=client">Zune</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=286971585">iTunes</option><option
value="0"></option><option
value="0">-- ASK NOAH --</option><option
value="https://asknoah.fireside.fm/rss">MP3 Audio RSS</option><option
value="http://feedpress.me/AskNoahHD">HD Video RSS</option><option
value="https://itunes.apple.com/us/podcast/id1221193873">iTunes MP3 RSS</option><option
value="0"></option><option
value="0">-- BSD NOW! --</option><option
value="http://feeds.feedburner.com/BsdNowMobile">Mobile Video RSS</option><option
value="http://feeds.feedburner.com/BsdNowHd">HD Video RSS</option><option
value="http://feeds.feedburner.com/BsdNowMp3">MP3 Audio RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/bsdnowhd/feed">HD Torrent RSS</option><option
value="0"></option><option
value="0">-- CODER RADIO --</option><option
value="http://itunes.apple.com/us/podcast/coder-radio-mp3/id534941512">iTunes MP3</option><option
value="http://itunes.apple.com/us/podcast/coder-radio-video/id534941251">iTunes Video</option><option
value="http://feeds.feedburner.com/coderradiovideo">Video RSS</option><option
value="http://feeds.feedburner.com/coderradiomp3">MP3 Audio RSS</option><option
value="0"></option><option
value="0">-- LINUX ACTION NEWS! --</option><option
value="http://linuxactionnews.com/rss">MP3 Audio RSS</option><option
value="https://itunes.apple.com/us/podcast/linux-action-news/id1235143849">iTunes MP3</option><option
value="0"></option><option
value="0">-- LINUX UNPLUGGED --</option><option
value="http://feeds.feedburner.com/linuxunplugged">MP3 Audio RSS</option><option
value="https://itunes.apple.com/us/podcast/linux-unplugged-podcast/id687598126">iTunes Audio</option><option
value="http://feeds.feedburner.com/linuxunvid">Video RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/linuxunvid/feed">Torrent RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/linuxunwebm/downloads.rss">WebM Torrent RSS</option><option
value="0"></option><option
value="0">-- TECHSNAP --</option><option
value="http://feeds.feedburner.com/techsnaphd">TechSNAP HD RSS</option><option
value="http://feeds.feedburner.com/techsnaplarge">TechSNAP Large RSS</option><option
value="http://feeds.feedburner.com/techsnapmobile">TechSNAP Mobile RSS</option><option
value="http://feeds.feedburner.com/techsnapmp3">TechSNAP MP3 RSS</option><option
value="http://itunes.apple.com/us/podcast/techsnap-in-hd/id433058842">TechSNAP iTunes HD</option><option
value="http://itunes.apple.com/us/podcast/techsnap-mobile-video/id433058959">TechSNAP iTunes Mobile</option><option
value="http://itunes.apple.com/us/podcast/techsnap-large-video/id433058851">TechSNAP iTunes Large</option><option
value="http://itunes.apple.com/us/podcast/techsnap-mp3/id433059024">TechSNAP iTunes MP3</option><option
value="0"></option><option
value="0">-- UNFILTER --</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterHD.xml">HD Video RSS</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterMob.xml">Mobile Video RSS</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterMP3.xml">MP3 Audio RSS</option><option
value="http://ax.search.itunes.apple.com/WebObjects/MZSearch.woa/wa/search?entity=podcast&media=all&page=1&restrict=true&startIndex=0&term=Unfilter">unfilter on iTunes</option><option
value="0"></option><option
value="0">-- USER ERROR --</option><option
value="https://feedpress.me/usererror">MP3 Audio</option><option
value="https://feedpress.me/uevideo">Video</option><option
value="https://itunes.apple.com/us/podcast/user-error-podcast/id1145648639">iTunes Audio</option><option
value="0"></option> </select></div></div></div></div><div
class="widget"><h3 class="widget-title">Support Jupiter Broadcasting</h3><div
class="widget-body"><div
class='support'><ul
class='inline icons'><li><a
href='https://www.patreon.com/jupitersignal' target="_blank"><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/PatreonJsignal.png"/></a></li><li
style="margin-right: 20px;"><a
href='https://www.patreon.com/unfilter' target="_blank"><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/PatreonUnfilter.png"/></a></li><li><form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"> <input
name="cmd" type="hidden" value="_s-xclick" /> <input
name="hosted_button_id" type="hidden" value="M5RAZYK4YW9RG" /> <input
alt="PayPal - The safer, easier way to pay online!" name="submit" src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/paypal5.png" type="image" /></form></li><li><form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"> <input
name="cmd" type="hidden" value="_s-xclick" /> <input
name="hosted_button_id" type="hidden" value="JT5XM8LDZ5UMQ" /> <input
alt="PayPal - The safer, easier way to pay online!" name="submit" src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/paypal10.png" type="image" /></form></li></ul></div></div></div><div
class="widget"><h3 class="widget-title">JB Stickers!!</h3><div
class="widget-body"><div
class="textwidget"><div
style="text-align: center;"><a
href="/stickers"><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/stickers/JupiterBroadcasting.png"></a><p>Jupiter Broadcasting stickers are now available!<br><a
href="/stickers">Click here</a> to get yours now!</p></div></div></div></div><div
class="widget"><h3 class="widget-title">Calendar</h3><div
class="widget-body"><script src="http://cdnjs.cloudflare.com/ajax/libs/jstimezonedetect/1.0.4/jstz.min.js"></script><script>/*<![CDATA[*/var calendarBase="http://www.google.com/calendar/embed?showTitle=0&showNav=0&showPrint=0&showTabs=0&showCalendars=0&mode=AGENDA&height=240&wkst=1&bgcolor=%23FFFFFF&src=jalb5frk4cunnaedbfemuqbhv4%40group.calendar.google.com&color=%235229A3&"
function updateCalendar()
{e=document.getElementById('ctz');document.getElementById("calendar").src=calendarBase+"ctz="+e.options[e.selectedIndex].value;}/*]]>*/</script><div
id="calendar-container" class='responsive-object-wrapper'></div> <select
name="ctz" id="ctz" onchange="updateCalendar()" class="full-width-field" style="max-width: 100%"><option>-- Select Your Timezone --</option><option
value="Pacific/Midway">(GMT-11:00) Midway</option><option
value="Pacific/Niue">(GMT-11:00) Niue</option><option
value="Pacific/Pago_Pago">(GMT-11:00) Pago Pago</option><option
value="Pacific/Honolulu">(GMT-10:00) Hawaii Time</option><option
value="Pacific/Johnston">(GMT-10:00) Johnston</option><option
value="Pacific/Rarotonga">(GMT-10:00) Rarotonga</option><option
value="Pacific/Tahiti">(GMT-10:00) Tahiti</option><option
value="Pacific/Marquesas">(GMT-09:30) Marquesas</option><option
value="America/Anchorage">(GMT-09:00) Alaska Time</option><option
value="Pacific/Gambier">(GMT-09:00) Gambier</option><option
value="America/Los_Angeles">(GMT-08:00) Pacific Time</option><option
value="America/Tijuana">(GMT-08:00) Pacific Time - Tijuana</option><option
value="America/Vancouver">(GMT-08:00) Pacific Time - Vancouver</option><option
value="America/Whitehorse">(GMT-08:00) Pacific Time - Whitehorse</option><option
value="Pacific/Pitcairn">(GMT-08:00) Pitcairn</option><option
value="America/Dawson_Creek">(GMT-07:00) Mountain Time - Dawson Creek</option><option
value="America/Denver">(GMT-07:00) Mountain Time</option><option
value="America/Edmonton">(GMT-07:00) Mountain Time - Edmonton</option><option
value="America/Hermosillo">(GMT-07:00) Mountain Time - Hermosillo</option><option
value="America/Mazatlan">(GMT-07:00) Mountain Time - Chihuahua, Mazatlan</option><option
value="America/Phoenix">(GMT-07:00) Mountain Time - Arizona</option><option
value="America/Yellowknife">(GMT-07:00) Mountain Time - Yellowknife</option><option
value="America/Belize">(GMT-06:00) Belize</option><option
value="America/Chicago">(GMT-06:00) Central Time</option><option
value="America/Costa_Rica">(GMT-06:00) Costa Rica</option><option
value="America/El_Salvador">(GMT-06:00) El Salvador</option><option
value="America/Guatemala">(GMT-06:00) Guatemala</option><option
value="America/Managua">(GMT-06:00) Managua</option><option
value="America/Mexico_City">(GMT-06:00) Central Time - Mexico City</option><option
value="America/Regina">(GMT-06:00) Central Time - Regina</option><option
value="America/Tegucigalpa">(GMT-06:00) Central Time - Tegucigalpa</option><option
value="America/Winnipeg">(GMT-06:00) Central Time - Winnipeg</option><option
value="Pacific/Easter">(GMT-06:00) Easter Island</option><option
value="Pacific/Galapagos">(GMT-06:00) Galapagos</option><option
value="America/Bogota">(GMT-05:00) Bogota</option><option
value="America/Cayman">(GMT-05:00) Cayman</option><option
value="America/Grand_Turk">(GMT-05:00) Grand Turk</option><option
value="America/Guayaquil">(GMT-05:00) Guayaquil</option><option
value="America/Havana">(GMT-05:00) Havana</option><option
value="America/Iqaluit">(GMT-05:00) Eastern Time - Iqaluit</option><option
value="America/Jamaica">(GMT-05:00) Jamaica</option><option
value="America/Lima">(GMT-05:00) Lima</option><option
value="America/Montreal">(GMT-05:00) Eastern Time - Montreal</option><option
value="America/Nassau">(GMT-05:00) Nassau</option><option
value="America/New_York">(GMT-05:00) Eastern Time</option><option
value="America/Panama">(GMT-05:00) Panama</option><option
value="America/Port-au-Prince">(GMT-05:00) Port-au-Prince</option><option
value="America/Toronto">(GMT-05:00) Eastern Time - Toronto</option><option
value="America/Caracas">(GMT-04:30) Caracas</option><option
value="America/Anguilla">(GMT-04:00) Anguilla</option><option
value="America/Antigua">(GMT-04:00) Antigua</option><option
value="America/Aruba">(GMT-04:00) Aruba</option><option
value="America/Asuncion">(GMT-04:00) Asuncion</option><option
value="America/Barbados">(GMT-04:00) Barbados</option><option
value="America/Boa_Vista">(GMT-04:00) Boa Vista</option><option
value="America/Campo_Grande">(GMT-04:00) Campo Grande</option><option
value="America/Cuiaba">(GMT-04:00) Cuiaba</option><option
value="America/Curacao">(GMT-04:00) Curacao</option><option
value="America/Dominica">(GMT-04:00) Dominica</option><option
value="America/Grenada">(GMT-04:00) Grenada</option><option
value="America/Guadeloupe">(GMT-04:00) Guadeloupe</option><option
value="America/Guyana">(GMT-04:00) Guyana</option><option
value="America/Halifax">(GMT-04:00) Atlantic Time - Halifax</option><option
value="America/La_Paz">(GMT-04:00) La Paz</option><option
value="America/Manaus">(GMT-04:00) Manaus</option><option
value="America/Martinique">(GMT-04:00) Martinique</option><option
value="America/Montserrat">(GMT-04:00) Montserrat</option><option
value="America/Port_of_Spain">(GMT-04:00) Port of Spain</option><option
value="America/Porto_Velho">(GMT-04:00) Porto Velho</option><option
value="America/Puerto_Rico">(GMT-04:00) Puerto Rico</option><option
value="America/Rio_Branco">(GMT-04:00) Rio Branco</option><option
value="America/Santiago">(GMT-04:00) Santiago</option><option
value="America/Santo_Domingo">(GMT-04:00) Santo Domingo</option><option
value="America/St_Kitts">(GMT-04:00) St. Kitts</option><option
value="America/St_Lucia">(GMT-04:00) St. Lucia</option><option
value="America/St_Thomas">(GMT-04:00) St. Thomas</option><option
value="America/St_Vincent">(GMT-04:00) St. Vincent</option><option
value="America/Thule">(GMT-04:00) Thule</option><option
value="America/Tortola">(GMT-04:00) Tortola</option><option
value="Antarctica/Palmer">(GMT-04:00) Palmer</option><option
value="Atlantic/Bermuda">(GMT-04:00) Bermuda</option><option
value="America/St_Johns">(GMT-03:30) Newfoundland Time - St. Johns</option><option
value="America/Araguaina">(GMT-03:00) Araguaina</option><option
value="America/Argentina/Buenos_Aires">(GMT-03:00) Buenos Aires</option><option
value="America/Bahia">(GMT-03:00) Salvador</option><option
value="America/Belem">(GMT-03:00) Belem</option><option
value="America/Cayenne">(GMT-03:00) Cayenne</option><option
value="America/Fortaleza">(GMT-03:00) Fortaleza</option><option
value="America/Godthab">(GMT-03:00) Godthab</option><option
value="America/Maceio">(GMT-03:00) Maceio</option><option
value="America/Miquelon">(GMT-03:00) Miquelon</option><option
value="America/Montevideo">(GMT-03:00) Montevideo</option><option
value="America/Paramaribo">(GMT-03:00) Paramaribo</option><option
value="America/Recife">(GMT-03:00) Recife</option><option
value="America/Sao_Paulo">(GMT-03:00) Sao Paulo</option><option
value="Antarctica/Rothera">(GMT-03:00) Rothera</option><option
value="Atlantic/Stanley">(GMT-03:00) Stanley</option><option
value="America/Noronha">(GMT-02:00) Noronha</option><option
value="Atlantic/South_Georgia">(GMT-02:00) South Georgia</option><option
value="America/Scoresbysund">(GMT-01:00) Scoresbysund</option><option
value="Atlantic/Azores">(GMT-01:00) Azores</option><option
value="Atlantic/Cape_Verde">(GMT-01:00) Cape Verde</option><option
value="Africa/Abidjan">(GMT+00:00) Abidjan</option><option
value="Africa/Accra">(GMT+00:00) Accra</option><option
value="Africa/Bamako">(GMT+00:00) Bamako</option><option
value="Africa/Banjul">(GMT+00:00) Banjul</option><option
value="Africa/Bissau">(GMT+00:00) Bissau</option><option
value="Africa/Casablanca">(GMT+00:00) Casablanca</option><option
value="Africa/Conakry">(GMT+00:00) Conakry</option><option
value="Africa/Dakar">(GMT+00:00) Dakar</option><option
value="Africa/El_Aaiun">(GMT+00:00) El Aaiun</option><option
value="Africa/Freetown">(GMT+00:00) Freetown</option><option
value="Africa/Lome">(GMT+00:00) Lome</option><option
value="Africa/Monrovia">(GMT+00:00) Monrovia</option><option
value="Africa/Nouakchott">(GMT+00:00) Nouakchott</option><option
value="Africa/Ouagadougou">(GMT+00:00) Ouagadougou</option><option
value="Africa/Sao_Tome">(GMT+00:00) Sao Tome</option><option
value="America/Danmarkshavn">(GMT+00:00) Danmarkshavn</option><option
value="Atlantic/Canary">(GMT+00:00) Canary Islands</option><option
value="Atlantic/Faroe">(GMT+00:00) Faeroe</option><option
value="Atlantic/Reykjavik">(GMT+00:00) Reykjavik</option><option
value="Atlantic/St_Helena">(GMT+00:00) St Helena</option><option
value="Etc/GMT">(GMT+00:00) GMT (no daylight saving)</option><option
value="Europe/Dublin">(GMT+00:00) Dublin</option><option
value="Europe/Lisbon">(GMT+00:00) Lisbon</option><option
value="Europe/London">(GMT+00:00) London</option><option
value="Africa/Algiers">(GMT+01:00) Algiers</option><option
value="Africa/Bangui">(GMT+01:00) Bangui</option><option
value="Africa/Brazzaville">(GMT+01:00) Brazzaville</option><option
value="Africa/Ceuta">(GMT+01:00) Ceuta</option><option
value="Africa/Douala">(GMT+01:00) Douala</option><option
value="Africa/Kinshasa">(GMT+01:00) Kinshasa</option><option
value="Africa/Lagos">(GMT+01:00) Lagos</option><option
value="Africa/Libreville">(GMT+01:00) Libreville</option><option
value="Africa/Luanda">(GMT+01:00) Luanda</option><option
value="Africa/Malabo">(GMT+01:00) Malabo</option><option
value="Africa/Ndjamena">(GMT+01:00) Ndjamena</option><option
value="Africa/Niamey">(GMT+01:00) Niamey</option><option
value="Africa/Porto-Novo">(GMT+01:00) Porto-Novo</option><option
value="Africa/Tripoli">(GMT+01:00) Tripoli</option><option
value="Africa/Tunis">(GMT+01:00) Tunis</option><option
value="Africa/Windhoek">(GMT+01:00) Windhoek</option><option
value="Europe/Amsterdam">(GMT+01:00) Amsterdam</option><option
value="Europe/Andorra">(GMT+01:00) Andorra</option><option
value="Europe/Belgrade">(GMT+01:00) Central European Time - Belgrade</option><option
value="Europe/Berlin">(GMT+01:00) Berlin</option><option
value="Europe/Brussels">(GMT+01:00) Brussels</option><option
value="Europe/Budapest">(GMT+01:00) Budapest</option><option
value="Europe/Copenhagen">(GMT+01:00) Copenhagen</option><option
value="Europe/Gibraltar">(GMT+01:00) Gibraltar</option><option
value="Europe/Luxembourg">(GMT+01:00) Luxembourg</option><option
value="Europe/Madrid">(GMT+01:00) Madrid</option><option
value="Europe/Malta">(GMT+01:00) Malta</option><option
value="Europe/Monaco">(GMT+01:00) Monaco</option><option
value="Europe/Oslo">(GMT+01:00) Oslo</option><option
value="Europe/Paris">(GMT+01:00) Paris</option><option
value="Europe/Prague">(GMT+01:00) Central European Time - Prague</option><option
value="Europe/Rome">(GMT+01:00) Rome</option><option
value="Europe/Stockholm">(GMT+01:00) Stockholm</option><option
value="Europe/Tirane">(GMT+01:00) Tirane</option><option
value="Europe/Vaduz">(GMT+01:00) Vaduz</option><option
value="Europe/Vienna">(GMT+01:00) Vienna</option><option
value="Europe/Warsaw">(GMT+01:00) Warsaw</option><option
value="Europe/Zurich">(GMT+01:00) Zurich</option><option
value="Africa/Blantyre">(GMT+02:00) Blantyre</option><option
value="Africa/Bujumbura">(GMT+02:00) Bujumbura</option><option
value="Africa/Cairo">(GMT+02:00) Cairo</option><option
value="Africa/Gaborone">(GMT+02:00) Gaborone</option><option
value="Africa/Harare">(GMT+02:00) Harare</option><option
value="Africa/Johannesburg">(GMT+02:00) Johannesburg</option><option
value="Africa/Kigali">(GMT+02:00) Kigali</option><option
value="Africa/Lubumbashi">(GMT+02:00) Lubumbashi</option><option
value="Africa/Lusaka">(GMT+02:00) Lusaka</option><option
value="Africa/Maputo">(GMT+02:00) Maputo</option><option
value="Africa/Maseru">(GMT+02:00) Maseru</option><option
value="Africa/Mbabane">(GMT+02:00) Mbabane</option><option
value="Asia/Amman">(GMT+02:00) Amman</option><option
value="Asia/Beirut">(GMT+02:00) Beirut</option><option
value="Asia/Damascus">(GMT+02:00) Damascus</option><option
value="Asia/Gaza">(GMT+02:00) Gaza</option><option
value="Asia/Jerusalem">(GMT+02:00) Jerusalem</option><option
value="Asia/Nicosia">(GMT+02:00) Nicosia</option><option
value="Europe/Athens">(GMT+02:00) Athens</option><option
value="Europe/Bucharest">(GMT+02:00) Bucharest</option><option
value="Europe/Chisinau">(GMT+02:00) Chisinau</option><option
value="Europe/Helsinki">(GMT+02:00) Helsinki</option><option
value="Europe/Istanbul">(GMT+02:00) Istanbul</option><option
value="Europe/Kiev">(GMT+02:00) Kiev</option><option
value="Europe/Riga">(GMT+02:00) Riga</option><option
value="Europe/Sofia">(GMT+02:00) Sofia</option><option
value="Europe/Tallinn">(GMT+02:00) Tallinn</option><option
value="Europe/Vilnius">(GMT+02:00) Vilnius</option><option
value="Africa/Addis_Ababa">(GMT+03:00) Addis Ababa</option><option
value="Africa/Asmara">(GMT+03:00) Asmera</option><option
value="Africa/Dar_es_Salaam">(GMT+03:00) Dar es Salaam</option><option
value="Africa/Djibouti">(GMT+03:00) Djibouti</option><option
value="Africa/Kampala">(GMT+03:00) Kampala</option><option
value="Africa/Khartoum">(GMT+03:00) Khartoum</option><option
value="Africa/Mogadishu">(GMT+03:00) Mogadishu</option><option
value="Africa/Nairobi">(GMT+03:00) Nairobi</option><option
value="Antarctica/Syowa">(GMT+03:00) Syowa</option><option
value="Asia/Aden">(GMT+03:00) Aden</option><option
value="Asia/Baghdad">(GMT+03:00) Baghdad</option><option
value="Asia/Bahrain">(GMT+03:00) Bahrain</option><option
value="Asia/Kuwait">(GMT+03:00) Kuwait</option><option
value="Asia/Qatar">(GMT+03:00) Qatar</option><option
value="Asia/Riyadh">(GMT+03:00) Riyadh</option><option
value="Europe/Kaliningrad">(GMT+03:00) Moscow-01 - Kaliningrad</option><option
value="Europe/Minsk">(GMT+03:00) Minsk</option><option
value="Indian/Antananarivo">(GMT+03:00) Antananarivo</option><option
value="Indian/Comoro">(GMT+03:00) Comoro</option><option
value="Indian/Mayotte">(GMT+03:00) Mayotte</option><option
value="Asia/Tehran">(GMT+03:30) Tehran</option><option
value="Asia/Baku">(GMT+04:00) Baku</option><option
value="Asia/Dubai">(GMT+04:00) Dubai</option><option
value="Asia/Muscat">(GMT+04:00) Muscat</option><option
value="Asia/Tbilisi">(GMT+04:00) Tbilisi</option><option
value="Asia/Yerevan">(GMT+04:00) Yerevan</option><option
value="Europe/Moscow">(GMT+04:00) Moscow+00</option><option
value="Europe/Samara">(GMT+04:00) Moscow+00 - Samara</option><option
value="Indian/Mahe">(GMT+04:00) Mahe</option><option
value="Indian/Mauritius">(GMT+04:00) Mauritius</option><option
value="Indian/Reunion">(GMT+04:00) Reunion</option><option
value="Asia/Kabul">(GMT+04:30) Kabul</option><option
value="Antarctica/Mawson">(GMT+05:00) Mawson</option><option
value="Asia/Aqtau">(GMT+05:00) Aqtau</option><option
value="Asia/Aqtobe">(GMT+05:00) Aqtobe</option><option
value="Asia/Ashgabat">(GMT+05:00) Ashgabat</option><option
value="Asia/Dushanbe">(GMT+05:00) Dushanbe</option><option
value="Asia/Karachi">(GMT+05:00) Karachi</option><option
value="Asia/Tashkent">(GMT+05:00) Tashkent</option><option
value="Indian/Kerguelen">(GMT+05:00) Kerguelen</option><option
value="Indian/Maldives">(GMT+05:00) Maldives</option><option
value="Asia/Calcutta">(GMT+05:30) India Standard Time</option><option
value="Asia/Colombo">(GMT+05:30) Colombo</option><option
value="Asia/Katmandu">(GMT+05:45) Katmandu</option><option
value="Antarctica/Vostok">(GMT+06:00) Vostok</option><option
value="Asia/Almaty">(GMT+06:00) Almaty</option><option
value="Asia/Bishkek">(GMT+06:00) Bishkek</option><option
value="Asia/Dhaka">(GMT+06:00) Dhaka</option><option
value="Asia/Thimphu">(GMT+06:00) Thimphu</option><option
value="Asia/Yekaterinburg">(GMT+06:00) Moscow+02 - Yekaterinburg</option><option
value="Indian/Chagos">(GMT+06:00) Chagos</option><option
value="Asia/Rangoon">(GMT+06:30) Rangoon</option><option
value="Indian/Cocos">(GMT+06:30) Cocos</option><option
value="Antarctica/Davis">(GMT+07:00) Davis</option><option
value="Asia/Bangkok">(GMT+07:00) Bangkok</option><option
value="Asia/Hovd">(GMT+07:00) Hovd</option><option
value="Asia/Jakarta">(GMT+07:00) Jakarta</option><option
value="Asia/Omsk">(GMT+07:00) Moscow+03 - Omsk, Novosibirsk</option><option
value="Asia/Phnom_Penh">(GMT+07:00) Phnom Penh</option><option
value="Asia/Saigon">(GMT+07:00) Hanoi</option><option
value="Asia/Vientiane">(GMT+07:00) Vientiane</option><option
value="Indian/Christmas">(GMT+07:00) Christmas</option><option
value="Antarctica/Casey">(GMT+08:00) Casey</option><option
value="Asia/Brunei">(GMT+08:00) Brunei</option><option
value="Asia/Choibalsan">(GMT+08:00) Choibalsan</option><option
value="Asia/Hong_Kong">(GMT+08:00) Hong Kong</option><option
value="Asia/Krasnoyarsk">(GMT+08:00) Moscow+04 - Krasnoyarsk</option><option
value="Asia/Kuala_Lumpur">(GMT+08:00) Kuala Lumpur</option><option
value="Asia/Macau">(GMT+08:00) Macau</option><option
value="Asia/Makassar">(GMT+08:00) Makassar</option><option
value="Asia/Manila">(GMT+08:00) Manila</option><option
value="Asia/Shanghai">(GMT+08:00) China Time - Beijing</option><option
value="Asia/Singapore">(GMT+08:00) Singapore</option><option
value="Asia/Taipei">(GMT+08:00) Taipei</option><option
value="Asia/Ulaanbaatar">(GMT+08:00) Ulaanbaatar</option><option
value="Australia/Perth">(GMT+08:00) Western Time - Perth</option><option
value="Asia/Dili">(GMT+09:00) Dili</option><option
value="Asia/Irkutsk">(GMT+09:00) Moscow+05 - Irkutsk</option><option
value="Asia/Jayapura">(GMT+09:00) Jayapura</option><option
value="Asia/Pyongyang">(GMT+09:00) Pyongyang</option><option
value="Asia/Seoul">(GMT+09:00) Seoul</option><option
value="Asia/Tokyo">(GMT+09:00) Tokyo</option><option
value="Pacific/Palau">(GMT+09:00) Palau</option><option
value="Australia/Adelaide">(GMT+09:30) Central Time - Adelaide</option><option
value="Australia/Darwin">(GMT+09:30) Central Time - Darwin</option><option
value="Antarctica/DumontDUrville">(GMT+10:00) Dumont D&#39;Urville</option><option
value="Asia/Yakutsk">(GMT+10:00) Moscow+06 - Yakutsk</option><option
value="Australia/Brisbane">(GMT+10:00) Eastern Time - Brisbane</option><option
value="Australia/Hobart">(GMT+10:00) Eastern Time - Hobart</option><option
value="Australia/Sydney">(GMT+10:00) Eastern Time - Melbourne, Sydney</option><option
value="Pacific/Guam">(GMT+10:00) Guam</option><option
value="Pacific/Port_Moresby">(GMT+10:00) Port Moresby</option><option
value="Pacific/Saipan">(GMT+10:00) Saipan</option><option
value="Pacific/Truk">(GMT+10:00) Truk</option><option
value="Asia/Vladivostok">(GMT+11:00) Moscow+07 - Yuzhno-Sakhalinsk</option><option
value="Pacific/Efate">(GMT+11:00) Efate</option><option
value="Pacific/Guadalcanal">(GMT+11:00) Guadalcanal</option><option
value="Pacific/Kosrae">(GMT+11:00) Kosrae</option><option
value="Pacific/Noumea">(GMT+11:00) Noumea</option><option
value="Pacific/Ponape">(GMT+11:00) Ponape</option><option
value="Pacific/Norfolk">(GMT+11:30) Norfolk</option><option
value="Asia/Kamchatka">(GMT+12:00) Moscow+08 - Petropavlovsk-Kamchatskiy</option><option
value="Asia/Magadan">(GMT+12:00) Moscow+08 - Magadan</option><option
value="Pacific/Auckland">(GMT+12:00) Auckland</option><option
value="Pacific/Fiji">(GMT+12:00) Fiji</option><option
value="Pacific/Funafuti">(GMT+12:00) Funafuti</option><option
value="Pacific/Kwajalein">(GMT+12:00) Kwajalein</option><option
value="Pacific/Majuro">(GMT+12:00) Majuro</option><option
value="Pacific/Nauru">(GMT+12:00) Nauru</option><option
value="Pacific/Tarawa">(GMT+12:00) Tarawa</option><option
value="Pacific/Wake">(GMT+12:00) Wake</option><option
value="Pacific/Wallis">(GMT+12:00) Wallis</option><option
value="Pacific/Apia">(GMT+13:00) Apia</option><option
value="Pacific/Enderbury">(GMT+13:00) Enderbury</option><option
value="Pacific/Fakaofo">(GMT+13:00) Fakaofo</option><option
value="Pacific/Tongatapu">(GMT+13:00) Tongatapu</option><option
value="Pacific/Kiritimati">(GMT+14:00) Kiritimati</option> </select> <script>var tz=jstz.determine();var tzname=encodeURIComponent(tz.name());var calendar=document.createElement("iframe");calendar.frameBorder=0;calendar.width="100%";calendar.height="240px";calendar.id="calendar";calendar.src=calendarBase+"ctz="+tzname
calendar.setAttribute("src",calendar.src);document.getElementById("calendar-container").appendChild(calendar);</script></div></div></div></div></div></div><div
id="footer-spacer"></div><div
id="footer"><div
class="container"><div
class="afflinks"><p><strong>Support Jupiter Broadcasting while shopping at:</strong></p><p> <a
href="http://www.amazon.co.uk/?tag=jupitebroa062-21">Amazon UK</a> <a
href="http://rover.ebay.com/rover/1/711-53200-19255-0/1?icep_ff3=1&pub=5575027880&toolid=10001&campid=5337188513&customid=&ipn=psmain&icep_vectorid=229466&kwid=902099&mtid=824&kw=lg">eBay</a> <a
href="http://www.kqzyfj.com/click-4897915-10784884">Think Geek</a> <a
href="http://www.woot.com/?utm_campaign=Commission+Junction+-+10848750&utm_source=Commission+Junction+Publisher+-+4897915&utm_medium=affiliate+-+Woot%21+Logo">Woot!</a> <a
href="http://www.dpbolvw.net/click-4897915-10298646">Audible</a> <a
href="http://zfer.us/iln1s">Code School</a> <a
href="http://www.anrdoezrs.net/click-4897915-10606699">NewEgg CA</a></p></div><div
class="licensecopy"><p
class="license">Our shows are licensed under <a
href="http://creativecommons.org/licenses/by-sa/4.0/"><strong>Creative Commons BY-SA 4.0</strong></a></p><p
class="copyright">2017 JupiterBroadcasting.com - All Rights Reserved</p></div></div></div><script type='text/javascript' src='//vjs.zencdn.net/4.12/video.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/themes/jb2014/scripts/video-quality-selector.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/themes/jb2014/scripts/videojs-seek.min.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/plugins//automatic-video-posts/js/scripts.js?ver=1.0'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-includes/js/wp-embed.min.js?ver=4.5.9'></script><script>/*<![CDATA[*/jQuery(function($){$('#contentleft').on('click','.loadmore',function(e){e.preventDefault();var $this=$(this);if(!$this.hasClass('loading')){$this.addClass('loading');$this.html('<i class="fa fa-fw fa-spinner fa-spin"></i> Loading...');$.get(this.href).done(function(response){$(response).find('.videoitem').appendTo('#videogallery');$this.replaceWith($(response).find('.loadmore').get(0));});}});});/*]]>*/</script><script type="text/javascript">videojs('video').ready(function(){var myPlayer=this,id=myPlayer.id();var aspectRatio=264/640;function resizeVideoJS(){var width=document.getElementById(id).parentElement.offsetWidth;myPlayer.width(width).height(width*aspectRatio);}
resizeVideoJS();window.onresize=resizeVideoJS;});</script>