<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html
xmlns="http://www.w3.org/1999/xhtml" lang="en-US"><head
profile="http://gmpg.org/xfn/11"><link
rel="stylesheet" type="text/css" href="http://jb.cdn.scaleengine.net/wp-content/cache/minify/000000/e7f88/default.include.e564b7.css" media="all" /><script type="text/javascript" src="http://jb2.cdn.scaleengine.net/wp-content/cache/minify/000000/e7f88/default.include.982d59.js"></script><meta
http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title>Compile once, debug twice | BSD Now 223 | Jupiter Broadcasting</title><meta
name="viewport" content="width=device-width, initial-scale=1.0" /><link
rel="alternate" type="application/rss+xml" title="Jupiter Broadcasting RSS Feed" href="http://www.jupiterbroadcasting.com/feed/" /><link
rel="pingback" href="http://www.jupiterbroadcasting.com/xmlrpc.php" /><meta
property="og:image" content="http://jb7.cdn.scaleengine.net/wp-content/uploads/2017/12/bsd-0223-v.jpg"/><link
rel="image_src" href="http://jb7.cdn.scaleengine.net/wp-content/uploads/2017/12/bsd-0223-v.jpg"/><link
rel="shortcut icon" href="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/favicon.ico" type="image/x-icon"><link
rel="icon" href="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/favicon.ico" type="image/x-icon"><link
rel="author" href="https://plus.google.com/b/105226975130718072838/+JupiterBroadcasting/posts" /><meta
name="description" itemprop="description" content="Picking a compiler for debuggability, how to port Rust apps to FreeBSD, what the point of Docker is on FreeBSD/Solaris, EuroBSDcon & network manager in OpenBSD." /><meta
name="keywords" itemprop="keywords" content="freebsd,openbsd,netbsd,dragonflybsd,trueos,tutorial,howto,guide,bsd,interview,bsd now,featured,video" /><link
rel="canonical" href="http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" /><script type="text/javascript">var _gaq=_gaq||[];_gaq.push(['_setAccount','UA-1721760-1']);_gaq.push(['_trackPageview']);(function(){var ga=document.createElement('script');ga.type='text/javascript';ga.async=true;ga.src=('https:'==document.location.protocol?'https://ssl':'http://www')+'.google-analytics.com/ga.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(ga,s);})();</script><script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.jupiterbroadcasting.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.11"}};!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link
rel='stylesheet' id='video-js-css-css'  href='//vjs.zencdn.net/4.12/video-js.css' type='text/css' media='all' /><link
rel='stylesheet' id='video-quality-selector-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/video-quality-selector.css' type='text/css' media='all' /><link
rel='stylesheet' id='ayvpp-style-css'  href='http://jb.cdn.scaleengine.net/wp-content/plugins//automatic-video-posts/css/style.css?ver=4.0' type='text/css' media='all' /><link
rel='stylesheet' id='bootstrap-css'  href='//netdna.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css' type='text/css' media='all' /><link
rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu:400,700' type='text/css' media='all' /><link
rel='stylesheet' id='font-awesome-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/bower_components/font-awesome/css/font-awesome.min.css?ver=2017042901' type='text/css' media='all' /><link
rel='stylesheet' id='default-css'  href='http://jb.cdn.scaleengine.net/wp-content/themes/jb2014/style.css?ver=2017042901' type='text/css' media='all' /><script type='text/javascript' src='//code.jquery.com/jquery-3.1.0.min.js'></script><script type='text/javascript' src='//netdna.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js'></script><link
rel='https://api.w.org/' href='http://www.jupiterbroadcasting.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.jupiterbroadcasting.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.jupiterbroadcasting.com/wp-includes/wlwmanifest.xml" /><link
rel='prev' title='Premature Collusion | Unfilter 262' href='http://www.jupiterbroadcasting.com/120467/premature-collusion-unfilter-262/' /><meta
name="generator" content="WordPress 4.5.11" /><link
rel='shortlink' href='http://www.jupiterbroadcasting.com/?p=120482' /><link
rel="alternate" type="application/json+oembed" href="http://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.jupiterbroadcasting.com%2F120482%2Fcompile-once-debug-twice-bsd-now-223%2F" /><link
rel="alternate" type="text/xml+oembed" href="http://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.jupiterbroadcasting.com%2F120482%2Fcompile-once-debug-twice-bsd-now-223%2F&#038;format=xml" /> <script type="text/javascript">/*<![CDATA[*/function limitChars(textid,limit,infodiv)
{var text=jQuery('#'+textid).val();var textlength=text.length;if(textlength>limit)
{jQuery('#'+infodiv).html('You cannot write more then '+limit+' characters!');jQuery('#'+textid).val(text.substr(0,limit));return false;}
else
{jQuery('#'+infodiv).html('You have '+(limit-textlength)+' characters left.');return true;}}
function displayVals(){var t3=jQuery("#t3").val();var amount=jQuery("#amount").val();if(t3!=0){jQuery('#a3').val(amount);jQuery('#p3').val(1);jQuery('#cmd').val('_xclick-subscriptions')}else{jQuery('#a3').val(0);jQuery('#p3').val(0);jQuery('#cmd').val('_donations');}
if(!t3)jQuery('#cmd').val('_donations');}
jQuery(function(){jQuery('#donor_comment').keyup(function(){limitChars('donor_comment',199,'charinfo');})
jQuery("#amount").change(displayVals);jQuery("#t3").change(displayVals);displayVals();var WallOps1='<p class="show_onwall" id="wallops"><input type="hidden" name="item_number" value="0:0" /></p>';var WallOps2='<p class="show_onwall" id="wallops"><label for="show_onwall">Show on Wall:</label><br /><select name="item_number"><option value="1:0">Donation Amount, User Details &amp; Comments</option><option value="2:0" selected="selected">User Details &amp; Comments Only</option></select></p>';if(jQuery('#recognize').is(':checked')==false){jQuery('#wallinfo').hide();jQuery("#wallops").html(WallOps1);}
jQuery("#recognize").click(function(){jQuery("#wallinfo").toggle('slow');if(jQuery('#wallops input').val()=='0:0'){jQuery("#wallops").html(WallOps2);}else{jQuery("#wallops").html(WallOps1);}})});/*]]>*/</script><script>(function(){var t,i,e,n=window,o=document,a=arguments,s="script",r=["config","track","identify","visit","push","call"],c=function(){var t,i=this;for(i._e=[],t=0;r.length>t;t++)(function(t){i[t]=function(){return i._e.push([t].concat(Array.prototype.slice.call(arguments,0))),i}})(r[t])};for(n._w=n._w||{},t=0;a.length>t;t++)n._w[a[t]]=n[a[t]]=n[a[t]]||new c;i=o.createElement(s),i.async=1,i.src="//static.woopra.com/js/w.js",e=o.getElementsByTagName(s)[0],e.parentNode.insertBefore(i,e)})("woopra");woopra.config({"app":"wordpress","download_tracking":false,"outgoing_tracking":false,"hide_campaign":false});woopra.track();</script><link
rel="amphtml" href="http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/amp/" /></head><body
class="single single-post postid-120482 single-format-standard"><div
id="header"><div
id="logo" class='hidden-md hidden-lg'><div
class="wrapper"> <a
href="http://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img
src="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/images/logo.png" alt="Jupiter Broadcasting" /></a></div></div><div
class="container"><nav
class='navbar navbar-default' role="navigation"><div
class="navbar-header"> <button
type='button' class='navbar-toggle' data-toggle='collapse' data-target='#main-menu'> <span
class="sr-only">Toggle navigation</span> <span
class="icon-bar"></span> <span
class="icon-bar"></span> <span
class="icon-bar"></span> </button></div><div
id="main-menu" class="collapse navbar-collapse"><ul
id="menu-main-menu" class="nav navbar-nav"><li
id="menu-item-34721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-34721"><a
title="Home" href="http://www.jupiterbroadcasting.com">Home</a></li><li
id="menu-item-34726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34726 dropdown"><a
title="Shows" href="#" data-toggle="dropdown" class="dropdown-toggle">Shows <span
class="caret"></span></a><ul
role="menu" class=" dropdown-menu"><li
id="menu-item-113496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113496"><a
title="Ask Noah" href="http://www.jupiterbroadcasting.com/show/asknoah/">Ask Noah</a></li><li
id="menu-item-42722" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-42722"><a
title="BSD Now" href="http://www.jupiterbroadcasting.com/show/bsdnow/">BSD Now</a></li><li
id="menu-item-34741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34741"><a
title="Coder Radio" href="http://www.jupiterbroadcasting.com/show/coderradio/">Coder Radio</a></li><li
id="menu-item-114676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114676"><a
title="Linux Action News" href="http://www.jupiterbroadcasting.com/show/linux-action-news/">Linux Action News</a></li><li
id="menu-item-41942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-41942"><a
title="LINUX Unplugged" href="http://www.jupiterbroadcasting.com/show/linuxun/">LINUX Unplugged</a></li><li
id="menu-item-34781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34781"><a
title="TechSNAP" href="http://www.jupiterbroadcasting.com/show/techsnap/">TechSNAP</a></li><li
id="menu-item-34786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34786"><a
title="Unfilter" href="http://www.jupiterbroadcasting.com/show/unfilter/">Unfilter</a></li><li
id="menu-item-88001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88001"><a
title="Rover Log" href="http://www.jupiterbroadcasting.com/show/rover-log/">Rover Log</a></li><li
id="menu-item-102376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102376"><a
title="User Error" href="http://www.jupiterbroadcasting.com/show/error/">User Error</a></li></ul></li><li
id="menu-item-34796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34796"><a
title="LIVE!" href="http://www.jupiterbroadcasting.com/watch-us-live/">LIVE!</a></li><li
id="menu-item-34801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34801"><a
title="Calendar" href="http://www.jupiterbroadcasting.com/release-calendar/">Calendar</a></li><li
id="menu-item-115491" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-115491"><a
title="Hosts" href="/hosts/">Hosts</a></li><li
id="menu-item-49972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49972 dropdown"><a
title="Archive" href="#" data-toggle="dropdown" class="dropdown-toggle">Archive <span
class="caret"></span></a><ul
role="menu" class=" dropdown-menu"><li
id="menu-item-49982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49982"><a
title="Beer is Tasty" href="http://www.jupiterbroadcasting.com/show/beeristasty/">Beer is Tasty</a></li><li
id="menu-item-49997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49997"><a
title="Computer Action Show" href="http://www.jupiterbroadcasting.com/show/cas/">Computer Action Show</a></li><li
id="menu-item-34746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34746"><a
title="FauxShow" href="http://www.jupiterbroadcasting.com/show/fauxshow/">FauxShow</a></li><li
id="menu-item-59332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332"><a
title="HowTo Linux" href="http://www.jupiterbroadcasting.com/show/h2l/">HowTo Linux</a></li><li
id="menu-item-50007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50007"><a
title="IN DEPTH LOOK" href="http://www.jupiterbroadcasting.com/show/indepthlook/">IN DEPTH LOOK</a></li><li
id="menu-item-50037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50037"><a
title="Joint Failures" href="http://www.jupiterbroadcasting.com/show/jointfailures/">Joint Failures</a></li><li
id="menu-item-50012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50012"><a
title="Jupiter@Nite" href="http://www.jupiterbroadcasting.com/show/nite/">Jupiter@Nite</a></li><li
id="menu-item-50042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50042"><a
title="Legend of the Stoned Owl" href="http://www.jupiterbroadcasting.com/show/legend-of-the-stoned-owl/">Legend of the Stoned Owl</a></li><li
id="menu-item-34766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34766"><a
title="Linux Action Show" href="http://www.jupiterbroadcasting.com/show/linuxactionshow/">Linux Action Show</a></li><li
id="menu-item-50017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50017"><a
title="MMOrgue" href="http://www.jupiterbroadcasting.com/show/mmorgue/">MMOrgue</a></li><li
id="menu-item-35751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35751"><a
title="Plan B" href="http://www.jupiterbroadcasting.com/show/planb/">Plan B</a></li><li
id="menu-item-34771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34771"><a
title="SciByte" href="http://www.jupiterbroadcasting.com/show/scibyte/">SciByte</a></li><li
id="menu-item-50022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50022"><a
title="STOked" href="http://www.jupiterbroadcasting.com/show/stoked/">STOked</a></li><li
id="menu-item-58772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58772"><a
title="Tech Talk Today" href="http://www.jupiterbroadcasting.com/show/today/">Tech Talk Today</a></li><li
id="menu-item-50027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50027"><a
title="TORked" href="http://www.jupiterbroadcasting.com/show/torked/">TORked</a></li><li
id="menu-item-71892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71892"><a
title="Women&#039;s Tech Radio" href="http://www.jupiterbroadcasting.com/show/wtr/">Women&#8217;s Tech Radio</a></li></ul></li><li
id="menu-item-34806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34806"><a
title="Contact" href="http://www.jupiterbroadcasting.com/contact/">Contact</a></li><li
id="menu-item-34811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34811"><a
title="Advertising" href="http://www.jupiterbroadcasting.com/advertising/">Advertising</a></li><li
id="menu-item-48917" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48917"><a
title="Forum" href="http://jupitercolony.com/">Forum</a></li><li
id="menu-item-34826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34826"><a
title="Donate" href="http://www.jupiterbroadcasting.com/support-us/">Donate</a></li></ul></div><form
method="get" id="searchForm" action="http://www.jupiterbroadcasting.com/" class='navbar-form navbar-right hidden-sm'> <input
placeholder="Search..." name="s" id="s" value="" /> <input
id="searchsubmit" type="image" src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/search.png" alt="Submit" /></form></nav></div></div><div
id="thevideo"><div
id="thevideoinside"><div
id="videoembed" class='container'><div
class='video responsive-object-wrapper vjs4'> <video
id="video" class="video-js vjs-default-skin vjs-big-play-centered" controls preload="none" width="854" height="506" poster="http://jb7.cdn.scaleengine.net/wp-content/uploads/2017/12/bsd-0223-v.jpg" data-setup='{ "plugins" : { "resolutionSelector" : { "default_res" : "SD" } } }' > <source
src="http://www.podtrac.com/pts/redirect.mp4/201406.jb-dl.cdn.scaleengine.net/bsdnow/2017/bsd-0223.mp4" type="video/mp4" data-res="HD" /><p
class="vjs-no-js">To view this video please enable JavaScript, and consider upgrading to a web browser that <a
href="http://videojs.com/html5-video-support/" target="_blank">supports HTML5 video</a></p> </video></div></div></div></div><div
id="content" class='container'><div
class='row'><div
id="contentleft" class='col-md-8 col-lg-9'><div
id=""><div
id="videodets" class='clearfix'><div
id="postinfo"><h2><a
href="http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" title="Compile once, debug twice | BSD Now 223">Compile once, debug twice | BSD Now 223</a></h2><p
class="itemlinks"></p><p
class="itemlinks">Posted on: <a
href="http://www.jupiterbroadcasting.com/date/2017/12/08/">December 7, 2017</a></p><p
class="itemlinks">Posted in: <a
href="http://www.jupiterbroadcasting.com/show/bsdnow/" rel="category tag">BSD Now</a>, <a
href="http://www.jupiterbroadcasting.com/show/featured/" rel="category tag">Featured</a>, <a
href="http://www.jupiterbroadcasting.com/show/video/" rel="category tag">Video</a></p><p
class="itemlinks"><a
href="#comments" title="Comment on This Video">Comment on This Video</a></p><p
class="itemlinks"><a
href="javascript:;" onmousedown="toggleSlide('sharearea');" title="Share this episode with others">Share This Video</a></p><div
id="sharearea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0; "><div
id="socialize"><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/delicious.gif" alt="del" /> <a
href="http://del.icio.us/post?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">del.icio.us</a></li><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/blinklist.gif" alt="blink" /> <a
href="http://blinklist.com/index.php?Action=Blink/addblink.php&Url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">blinklist</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/digg.gif" alt="digg" /> <a
href="http://digg.com/submit?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">digg</a></li><li><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/facebook.gif" alt="face" /> <a
href="http://www.facebook.com/share.php?u=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Facebook</a></li></ul></div><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/furl.gif" alt="furl" /> <a
href="http://furl.net/storeIt.jsp?u=&t=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Furl</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/magnolia.gif" alt="magnol" /> <a
href="http://ma.gnolia.com/bookmarklet/add?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">ma.gnolia</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/newsvine.gif" alt="newsv" /> <a
href="http://www.newsvine.com/_wine/save?u=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Newsvine</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/pownce.gif" alt="pownce" /> <a
href="http://pownce.com/send/link/?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Pownce</a></li></ul></div><div
style="float: left; width:150px;"><ul
style="list-style-type: none; line-height: 20px; padding-top: 5px;"><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/reddit.gif" alt="reddit" /> <a
href="http://reddit.com/submit?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">reddit</a></li><li><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/stumbleupon.gif" alt="stumble" /> <a
href="http://www.stumbleupon.com/submit?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">StumbleUpon</a></li><li><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/technorati.gif" alt="tech" /> <a
href="http://www.technorati.com/faves?add=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Technorati</a></li><li><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/share/twitter.gif" alt="twit" /> <a
href="http://twitthis.com/twit?url=http://www.jupiterbroadcasting.com/120482/compile-once-debug-twice-bsd-now-223/" target="_blank">Twitter</a></li></ul></div></div></div><p
class="itemlinks"><a
href="javascript:;" onmousedown="toggleSlide('embedarea');" title="Embed episode on your website">Embed This Video</a></p><div
id="embedarea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0;"><textarea name="thoughts" rows=4 style="border:1px solid #B8B8B8; width:642px; background:none; padding:5px; color:#565050; font-family:Arial, Helvetica, sans-serif; font-size: 12px; margin-top: 10px; overflow: hidden;"></textarea></div></div><div
class="thumbnail"> <img
width="300" height="178" src="http://jb7.cdn.scaleengine.net/wp-content/uploads/2017/12/bsd-0223-v-300x178.jpg" class="attachment-medium size-medium wp-post-image" alt="bsd-0223-v" srcset="http://jb5.cdn.scaleengine.net/wp-content/uploads/2017/12/bsd-0223-v-300x178.jpg 300w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/12/bsd-0223-v-200x120.jpg 200w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/12/bsd-0223-v-768x455.jpg 768w, http://www.jupiterbroadcasting.com/wp-content/uploads/2017/12/bsd-0223-v.jpg 854w" sizes="(max-width: 300px) 100vw, 300px" /></div></div><div
id="synopsis"><p>Picking a compiler for debuggability, how to port Rust apps to FreeBSD, what the point of Docker is on FreeBSD/Solaris, another EuroBSDcon recap &#038; network manager control in OpenBSD.</p></div><div
id="sponsors"><p><strong>Thanks to:</strong></p><p><a
href="https://www.digitalocean.com/?utm_source=BSDNow&amp;utm_medium=Podcast&amp;utm_campaign=BSD+Now+Podcast" target="_blank"><br
/> <img
src="http://jb5.cdn.scaleengine.net/wp-content/uploads/2015/01/do-bsd-freebsdnow.jpg" alt="DigitalOcean" height="70" border="0" /></a></p><ul><li><a
href="https://www.digitalocean.com/community/get-paid-to-write">Get Paid to Write for DigitalOcean</a></li></ul><p><a
href="http://www.ixsystems.com/bsdnow/" target="_blank"><br
/> <img
src="http://jb6.cdn.scaleengine.net/wp-content/uploads/2015/07/iXsystems-Banner-bsd-2015.jpg" alt="iXsystems" height="70" border="0" /></a><br
/> <a
href="http://www.tarsnap.com/bsdnow" target="_blank"><br
/> <img
src="http://jb6.cdn.scaleengine.net/wp-content/uploads/2014/05/Tarsnap-bsd-banner.jpg" alt="Tarsnap" height="70" border="0" /></a></p></div><div
id="direct-downloads"><h3>Direct Download:</h3><ul><li><a
href="http://www.podtrac.com/pts/redirect.mp4/201406.jb-dl.cdn.scaleengine.net/bsdnow/2017/bsd-0223.mp4">HD Video</a></li><li><a
href="http://www.podtrac.com/pts/redirect.mp3/traffic.libsyn.com/jnite/bsd-0223.mp3">MP3 Audio</a></li><li><a
href="http://bitlove.org/jupiterbroadcasting/bsdnowhd">Torrent</a></li><li><a
href="https://www.youtube.com/watch?v=f8fdKIC851g">YouTube</a></li></ul></div><div
id="postcontent"><h3>RSS Feeds:</h3><p><a
href="http://feeds.feedburner.com/BsdNowMp3">MP3 Feed</a> <strong>|</strong> <a
href="https://itunes.apple.com/us/podcast/bsd-now-mp3/id701045710?mt=2">iTunes Feed</a> <strong>|</strong> <a
href="http://feeds.feedburner.com/BsdNowHd">HD Vid Feed</a> <strong>|</strong> <a
href="http://bitlove.org/jupiterbroadcasting/bsdnowhd/feed">HD Torrent Feed</a></p><h3><a
href="http://www.patreon.com/jupitersignal">Become a supporter on Patreon</a>:</h3><p><a
href="http://www.patreon.com/jupitersignal" rel="Support us on Patreon"><img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/Patreon_logo_kit/Become a Patron Button/become_a_patron_button.png" alt="Patreon" /></a></p><h3>&#8211; Show Notes: &#8211;</h3><h2>Headlines</h2><h3><a
href="https://backtrace.io/blog/compile-once-debug-twice-picking-a-compiler-for-debuggability-1of3/">Compile once, Debug twice: Picking a compiler for debuggability, part 1 of 3</a></h3><ul><li>An interesting look into why when you try to debug a crash, you can often find all of the useful information has been ‘optimized out’</li></ul><blockquote><p>Have you ever had an assert get triggered only to result in a useless core dump with missing variable information or an invalid callstack?<br
/> Common factors that go into selecting a C or C++ compiler are: availability, correctness, compilation speed and application performance. A factor that is often neglected is debug information quality, which symbolic debuggers use to reconcile application executable state to the source-code form that is familiar to most software engineers.<br
/> When production builds of an application fail, the level of access to program state directly impacts the ability for a software engineer to investigate and fix a bug. If a compiler has optimized out a variable or is unable to express to a symbolic debugger how to reconstruct the value of a variable, the engineer’s investigation process is significantly impacted. Either the engineer has to attempt to recreate the problem, iterate through speculative fixes or attempt to perform prohibitively expensive debugging, such as reconstructing program state through executable code analysis.<br
/> Debug information quality is in fact not proportionally related to the quality of the generated executable code and wildly varies from compiler to compiler.<br
/> Different compilers emit debug information at varying levels of quality and accuracy. However, certain optimizations will certainly impact any debugger’s ability to generate accurate stack traces or extract variable values.<br
/> In the above program, the value of argv is extracted and then the program is paused. The ck_pr_load_ptr function performs a read from the region of memory pointed to by argv, in a manner that prevents the compiler from performing optimization on it. This ensures that the memory access occurs and for this reason, the value of argv must be accessible by the time ck_pr_load_ptr is executed.<br
/> When compiled with gcc, the debugger fails to find the value of the variable. The compiler determines that the value of argv is no longer needed after the ck_pr_load_ptr operation and so doesn’t bother paying the cost of saving the value.<br
/> Some optimizations generate executable code whose call stack cannot be sufficiently disambiguated to reconcile a call stack that mirrors that of the source program. Two common culprits for this are tail call optimization and basic block commoning.</p></blockquote><ul><li>In another example</li></ul><blockquote><p>If the program receives a first argument of 1, then function is called with the argument of &#8220;a&#8221;. If the program receives a first argument of 2, then function is called with the argument of &#8220;b&#8221;. However, if we compile this program with clang, the stack traces in both cases are identical! clang informs the debugger that the function f invoked the function(&#8220;b&#8221;) branch where x = 2 even if x = 1.<br
/> Though some optimizations will certainly impact the accuracy of a symbolic debugger, some compilers simply lack the ability to generate debug information in the presence of certain optimizations. One common optimization is induction variable elimination. A variable that’s incremented or decremented by a constant on every iteration of a loop or derived from another variable that follows this pattern, is an induction variable.<br
/> Coupled with other optimizations, the compiler is then able to generate code that doesn’t actually rely on a dedicated counter variable “i” for maintaining the current offset into “buffer”.<br
/> As you can see, i is completely optimized out. The compiler determines it doesn’t have to pay the cost of maintaining the induction variable i. It maintains the pointer in the register %rdi. The code is effectively rewritten to something closer to this:</p></blockquote><ul><li>So the for loop, changes into a while loop, with a condition of the end of the input</li></ul><blockquote><p>We have shown some common optimizations that may get in the way of the debuggability of your application and demonstrated a disparity in debug information quality across two popular compilers. In the next blog post of this series, we will examine how gcc and clang stack up with regards to debug information quality across a myriad of synthetic applications and real world applications.</p></blockquote><ul><li>Looking forward to part 2</li></ul><hr
/><h3><a
href="https://medium.com/@andoriyu/this-is-how-you-can-port-your-rust-application-to-freebsd-7d3e9f1bc3df">This is how you can port your rust application to FreeBSD</a></h3><ul><li>This is how you can port your rust application to FreeBSD</li></ul><blockquote><p>The FreeBSD Ports Collection is the way almost everyone installs applications (“ports”) on FreeBSD. Like everything else about FreeBSD, it is primarily a volunteer effort. It is important to keep this in mind when reading this document.<br
/> In FreeBSD, anyone may submit a new port, or volunteer to maintain an existing unmaintained port. No special commit privilege is needed.<br
/> For this guide I will use fd tool written by David Peter as example project.</p></blockquote><ul><li><p>Prerequisites</p><ul><li>FreeBSD installation (VM is fine)</li><li>Local ports tree (done via svn)</li><li>portlint (located at devel/portlint)</li><li>poudriere (located at ports-mgmt/poudriere)[optional]</li></ul></li><li><p>Getting ports tree</p><ul><li>When you install FreeBSD opt-out of the ports tree. Install svn:</li></ul></li></ul><p><code>pkg install svn<br
/> svn checkout https://svn.freebsd.org/ports/head /usr/ports</code></p><ul><li><p>Poudriere</p><blockquote><p>Sometimes you might get asked to show poudriere build log, sometimes you won’t. It’s good to have anyway. If you choose to use poudriere, use ZFS. There are plenty of guides on the subject. FreeBSD Porter’s Handbook is the most complete source of information on porting to FreeBSD.</p></blockquote></li><li><p>Makefile</p></li></ul><blockquote><p>Whole porting process in most cases is writing one Makefile. I recommend doing something like this.<br
/> Here is the one I wrote for fd:</p></blockquote><ul><li>Port metadata</li></ul><blockquote><p>Each port must have one primary category in case of fd it will be sysutils, therefore it&#8217;s located in /usr/ports/systuils/fd.</p></blockquote><p><code>PORTNAME= fd<br
/> CATEGORIES= sysutils</code></p><blockquote><p>Since this port conflicts with other util named fd I specified package suffix as: PKGNAMESUFFIX= -find and indicate conflict: CONFLICTS_INSTALL= fd-[0-9]*. That means to install it from packages user will have to type:</p></blockquote><p><code>pkg install fd-find</code></p><ul><li>Licenses</li></ul><blockquote><p>This section is different for every port, but in case of fd it&#8217;s pretty straightforward:</p></blockquote><p><code>LICENSE= MIT APACHE20<br
/> LICENSE_COMB= dual</code></p><blockquote><p>Since fd includes the text of licenses you should do this as well:</p></blockquote><p><code>LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT<br
/> LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE</code></p><ul><li>Distfiles</li></ul><blockquote><p>FreeBSD has a requirement that all ports must allow offline building. That means you have specified which files are needed to be downloaded. Luckily we now have helpers to download GitHub sources directly from GitHub:</p></blockquote><p><code>USE_GITHUB= yes<br
/> GH_ACCOUNT= sharkdp</code></p><blockquote><p>Since PORTNANE is fd it will try to download sources for sharkdp/fd. By default it&#8217;s going to download tag:</p></blockquote><p><code>${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}</code></p><blockquote><p>fd uses v as the prefix, therefore we need to specify: DISTVERSIONPREFIX= v.<br
/> It&#8217;s also possible to specify GH_TAGNAME in case tag name doesn&#8217;t match that pattern.</p></blockquote><ul><li>Extra packages</li></ul><blockquote><p>There are very few rust projects that are standalone and use no crates dependencies. It’s used to be PITA to make it work offline, but now cargo is a first class citizen in ports:</p></blockquote><p><code>USES= cargo<br
/> CARGO_CRATES= aho-corasick-0.6.3 \<br
/> atty-0.2.3 \<br
/> # and so goes on</code></p><blockquote><p>Yes, you have to specify each dependency. Luckily, there is a magic awk script that turns Cargo.lock into what you need. Execute make cargo-crates in the port root. This will fail because you&#8217;re missing checksum for the original source files:</p></blockquote><p><code>make makesum<br
/> make cargo-crates</code></p><blockquote><p>This will give you what you need. Double check that result is correct. There is a way to ignore checksum error, but I can’t remember… Execute make makesum again.</p></blockquote><ul><li>CARGO_OUT</li></ul><blockquote><p>If. build.rs relies on that you have to change it. fd allows you to use SHELL_COMPLETIONS_DIR to specify where completions go, while ripgrep doesn&#8217;t. In our case we just specify SHELL_COMPLETIONS_DIR:</p></blockquote><p><code>SHELL_COMPLETIONS_DIR= ${WRKDIR}/shell-completions-dir CARGO_ENV= SHELL_COMPLETIONS_DIR=${SHELL_COMPLETIONS_DIR}</code></p><ul><li>PLIST</li></ul><blockquote><p>FreeBSD is very strict about files it’s installing and it won’t allow you to install random files that get lost. You have to specify which files you’re installing. In this case, it’s just two:</p></blockquote><p><code>PLIST_FILES= bin/fd \<br
/> man/man1/fd.1.gz</code></p><blockquote><p>Note that sources for fd have uncompressed man file, while here it’s listed as compressed. If port installs a lot of files, specify them in pkg-plist like here. To actually install them:</p></blockquote><p><code>post-install:<br
/> @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fd<br
/> ${INSTALL_MAN}${WRKSRC}/doc/fd.1 ${STAGEDIR}${MAN1PREFIX}/man/man1</code></p><ul><li>Shell completions</li></ul><blockquote><p>clap-rs can generate shell completions for you, it&#8217;s usually handled by build.rs script. First, we need to define options:</p></blockquote><p><code>OPTIONS_DEFINE= BASH FISH ZSH # list options<br
/> OPTIONS_DEFAULT= BASH FISH ZSH # select them by default<br
/> BASH_PLIST_FILES= etc/bash_completion.d/fd.bash-completion<br
/> FISH_PLIST_FILES= share/fish/completions/fd.fish<br
/> ZSH_PLIST_FILES= share/zsh/site-functions/_fd</code></p><blockquote><p>To actually install them:</p></blockquote><p><code>post-install-BASH-on:<br
/> @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d<br
/> ${INSTALL_DATA} ${SHELL_COMPLETIONS_DIR}/fd.bash-completion \<br
/> ${STAGEDIR}${PREFIX}/etc/bash_completion.d<br
/> post-install-FISH-on:<br
/> @${MKDIR} ${STAGEDIR}${PREFIX}/share/fish/completions<br
/> ${INSTALL_DATA} ${SHELL_COMPLETIONS_DIR}/fd.fish \<br
/> ${STAGEDIR}${PREFIX}/share/fish/completions<br
/> post-install-ZSH-on:<br
/> @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions<br
/> ${INSTALL_DATA} ${SHELL_COMPLETIONS_DIR}/_fd \<br
/> ${STAGEDIR}${PREFIX}/share/zsh/site-functions</code></p><ul><li>Bonus round &#8211; Patching source code</li></ul><blockquote><p>Sometimes you have to patch it and send the patch upstream. Merging it upstream can take awhile, so you can patch it as part of the install process. An easy way to do it:</p></blockquote><ul><li>Go to work/ dir</li><li>Copy file you want to patch and add .orig suffix to it</li><li>Edit file you want to patch</li><li><p>Execute make makepatch in port&#8217;s root</p></li><li><p>Submitting port</p></li></ul><blockquote><p>First, make sure portlint -AC doesn&#8217;t give you any errors or warnings. Second, make sure poudriere can build it on both amd64 and i386. If it can&#8217;t — you have to either fix it or mark port broken for that arch.<br
/> Follow this steps like I did steps. If you have any issues you can always ask your question in freebsd-ports on freenode try to find your answer in porter’s handbook before asking.</p></blockquote><hr
/><h3><a
href="https://www.freebsdfoundation.org/blog/conference-recap-eurobsdcon-2017-recap/">Conference Recap: EuroBSDCon 2017 Recap</a></h3><blockquote><p>The location was wonderful and I loved sneaking out and exploring the city when I could. From what I heard, it was the largest BSD conference in history, with over 320 attendees!<br
/> Each venue is unique and draws many local BSD enthusiasts, who normally wouldn’t be able to travel to a conference. I love having the chance to talk to these people about how they are involved in the projects and what they would like to do. Most of the time, they are asking me questions about how they can get more involved and how we can help.<br
/> <em>Magical</em> is how I would describe the conference social event. To stand in front of the dinner cruise on the Seine, with the Eiffel Tower standing tall, lit up in the night, while working – talking to our community members, was incredible. But, let me start at the beginning.<br
/> We attend these conferences to talk to our community members, to find out what they are working on, determine technologies that should be supported in FreeBSD, and what we can do to help and improve FreeBSD.<br
/> We started the week with a half-day board meeting on Wednesday. BSD conferences give us a chance to not only meet with community members around the world, but to have face-to-face meetings with our team members, who are also located around the world. We worked on refining our strategic direction and goals, determining what upcoming conferences we want FreeBSD presence at and who can give FreeBSD talks and workshops there, discussed current and potential software development projects, and discussed how we can help raise awareness about and increase the use of FreeBSD in Europe.<br
/> Thursday was the first day of the FreeBSD developer summit, led by our very own Benedict Reuschling. He surprised us all by having us participate in a very clever quiz on France. 45 of us signed into the software, where he’d show the question on the screen and we had a limited amount of time to select our answers, with the results listed on the screen. It was actually a lot of fun, especially since they didn’t publicize the names of the people who got the questions wrong. The lucky or most knowledgeable person on France, was des@freebsd.org.<br
/> Some of our board members ran tutorials in parallel to the summit. Kirk McKusick gave his legendary tutorial,  An Introduction to the FreeBSD Open-Source Operating System , George Neville-Neil gave his tutorial, DTrace for Developers, and Benedict Reuschling gave a tutorial on, Managing BSD systems with Ansible.<br
/> I was pleased to have two chairs from ACM-W Europe run an “Increasing Diversity in the BSDs” BoF for the second year in a row. We broke up into three groups to discuss different gender bias situations, and what we can do to address these types of situations, to make the BSD projects more diverse, welcoming, and inclusive. At the end, people asked that we continue these discussions at future BSD conferences and suggested having an expert in the field give a talk on how to increase the diversity in our projects.<br
/> As I mentioned earlier, the social dinner was on a boat cruising along the Seine. I had a chance to talk to community members in a more social environment. With the conference being in France, we had a lot of first time attendees from France. I enjoyed talking to many of them, as well as other people I only get to see at the European conferences. Sunday was full of more presentations and conversations. During the closing session, I gave a short talk on the Foundation and the work we are doing. Then, Benedict Reuschling, Board Vice President, came up and gave out recognition awards to four FreeBSD contributors who have made an impact on the Project.</p></blockquote><hr
/><h2>News Roundup</h2><h3><a
href="https://chown.me/blog/playing-with-the-pine64.html">Playing with the pine64</a></h3><ul><li>Daniel Jakots writes in his blog about his experiences with his two pine64 boards:</li></ul><blockquote><p>Finding something to install on it<br
/> 6 weeks ago, I ordered two pine64 units. I didn&#8217;t (and still don&#8217;t) have much plan for them, but I wanted to play with some cheap boards. I finally received them this week. Initially I wanted to install some Linux stuff on it, I didn&#8217;t have much requirement so I thought I would just look what seems to be easy and/or the best supported systemd flavour. I headed over their wiki. Everything seems either not really maintained, done by some random people or both. I am not saying random people do bad things, just that installing some random things from the Internet is not really my cup of tea.<br
/> I heard about <a
href="https://www.armbian.com/pine64/">Armbian</a> but the server flavour seems to be experimental so I got scared of it. And sadly, the whole things looks like to be alot undermanned.<br
/> So I went for OpenBSD because I know the stuff and who to har^Wkindly ask for help. Spoiler alert, it&#8217;s boring because it just works.</p></blockquote><ul><li>Getting OpenBSD on it</li></ul><blockquote><p>I downloaded miniroot62.fs, dd&#8217;ed it on the micro SD card. I was afraid I&#8217;d need to fiddle with some things like sysutils/dtb because I don&#8217;t know what I would have needed to do. That&#8217;s because I don&#8217;t know what it does and for this precise reason I was wrong and I didn&#8217;t need to do anything. So just dd the miniroot62.fs and you can go to next checkpoint.<br
/> I plugged an HDMI cable, ethernet cable and the power, it booted, I could read for 10 seconds but then it got dark. Of course it&#8217;s because you need a serial console. Of course I didn&#8217;t have one.<br
/> I thought about trying to install OpenBSD blindly, I could have probably succeeded with autoinstall buuuuuut…<br
/> Following some good pieces of advice from OpenBSD people I bought some cp2102 (I didn&#8217;t try to understand what it was or what were the other possibilities, I just wanted something that would work :D).<br
/> I looked how to plug the thing. It appears you can plug it on two different places but if you plug it on the Euler bus it could power a bit the board so if you try to reboot it, it would then mess with the power disruption and could lead a unclean reboot.<br
/> You just need to plug three cables: GND, TXD and RXD. Of course, the TXD goes on the RXD pin from the picture and the RXD goes on the TXD pin. Guess why I&#8217;m telling you that!</p></blockquote><ul><li>That&#8217;s it</li><li>Then you can connect with the usual</li></ul><blockquote><p>$ cu -dl /dev/cuaU0 -s 115200</p></blockquote><hr
/><h3><a
href="http://blog.frankleonhardt.com/2017/whats-the-point-of-docker-on-freebsd-or-solaris/">What’s the point of Docker on FreeBSD or Solaris?</a></h3><blockquote><p>Penguinisters are very keen on their docker, but for the rest of us it may be difficult to see what the fuss is all about – it’s only been around a few years and everyone’s talking about it. And someone asked again today. What are we missing?<br
/> Well docker is a solution to a Linux (and Windows) problem that FreeBSD/Solaris doesn’t have. Until recently, the Linux kernel only implemented the original user isolation model involving chroot. More recent kernels have had Control Groups added, which are intended to provide isolation for a group of processes (namespaces). This came out of Google, and they’ve extended to concept to include processor resource allocation as one of the knobs, which could be a good idea for FreeBSD. The scheduler is aware of the JID of the process it’s about to schedule, and I might take a look in the forthcoming winter evenings. But I digress.<br
/> So if isolation (containerisation in Linux terms) is in the Linux kernel, what is Docker bringing to the party? The only thing I can think of is standardisation and an easy user interface (at the expense of having Python installed). You might think of it in similar terms to ezjail – a complex system intended to do something that is otherwise very simple.<br
/> To make a jail in FreeBSD all you need do is copy the files for your system  to a directory. This can even be a whole server’s system disk if you like, and jails can run inside jails.  You then create a very simple config file, giving the jail a name, the path to your files and an what IP addresses to pass through (if any) and you’re done. Just type “service jail nameofjal start”, and off it goes.<br
/> Is there any advantage in running Docker? Well, in a way, there is. Docker has a repository of system images that you can just install and run, and this is what a lot of people want. They’re a bit like virtual appliances, but not mind-numbingly inefficient.<br
/> You can actually run docker on FreeBSD. A port was done a couple of years ago, but it relies on the 64-bit Linux emulation that started to appear in 10.x. The newer the version of FreeBSD the better.<br
/> Docker is in ports/sysutils/docker-freebsd. It makes uses of jails instead of Linux cgroups, and requires ZFS rather than UFS for file system isolation. I believe the Linux version uses Union FS but I could be completely wrong on that.<br
/> The FreeBSD port works with the Docker hub repository, giving you access to thousands of pre-packaged system images to play with. And that’s about as far as I’ve ever tested it. If you want to run the really tricky stuff (like Windows) you probably want full hardware emulation and something like  Xen. If you want to deploy or migrate FreeBSD or Solaris systems, just copy a new tarball in to the directory and go. It’s a non-problem, so why make it more complicated?<br
/> Given the increasing frequency Docker turns up in conversations, it’s probably worth taking seriously as Linux applications get packaged up in to images for easy access. Jails/Zones may be more efficient, and Docker images are limited to binary, but convenience tends to win in many environments.</p></blockquote><hr
/><h3><a
href="http://www.vincentdelft.be/post/post_20171023">Network Manager Control for OpenBSD</a></h3><blockquote><p>I propose you a small script allowing you to easily manage your networks connections. This script is integrated within the openbox dynamic menus. Moreover, it allow you to automatically have the connections you have pre-defined based.<br
/> I was frustrated to not be able to swap quickly from one network interface to an another, to connect simply and quickly to my wifi, to my cable connection, to the wifi of a friend, &#8230;<br
/> Every time you have to type the ifconfig commands, &#8230;. This is nice, but boring. Surely, when you are in a middle of a presentation and you just want a quick connection to your mobile in tethering mode.<br
/> Thanks to OpenBSD those commands are not so hard, but this frustrate me to not be able to do it with one click. Directly from my windows environment. Since I&#8217;m using Openbox, from a menu of openbox.<br
/> So, I&#8217;ve looked around to see what is currently existing.<br
/> One tool I&#8217;ve found was <a
href="https://github.com/akpoff/netctl">netctl</a>. The idea is to have a repository of hostname.if files ready to use for different cases.<br
/> The idea sounds great, but I had some difficulties to use it.<br
/> But what annoys me the most, is that it modify the current hostname.if files in /etc.<br
/> To my eyes, I would avoid to modify those files because they are my working basis. I want to rely on them and make sure that my network will be back to a normal mode after a reboot.<br
/> Nevertheless, if I&#8217;ve well understood netctl, you have a feature where it will look for the predefined network config matching the environment where you are. Very cool.<br
/> So, after having played with netctl, look for alternative on internet, I&#8217;ve decided to create nmctl. A small python script which just perform the mandatory network commands.</p></blockquote><ul><li><ol><li>nmctl: a Network Manager Control tool for OpenBSD</li></ol></li></ul><blockquote><p>Nmctl a small tool that allow you to manage your network connections.<br
/> Why python ? Just because it&#8217;s the easiest programming language for me. But I should maybe rewrite it in shell, more standard in the OpenBSD world than python.</p></blockquote><ul><li>1.1. download and install</li></ul><blockquote><p>I&#8217;ve put nmctl on my sourceforge account <a
href="https://sourceforge.net/p/nmctl/code/ci/master/tree/">here</a><br
/> You can dowload the last version <a
href="https://sourceforge.net/p/nmctl/code/ci/master/tarball">here</a><br
/> To install you just have to run: make install (as root)<br
/> The per-requists are:<br
/> &#8211; having python2.7 installed<br
/> &#8211; Since nmctl must be run as root, I strongly recommend you to run it via <a
href="http://man.openbsd.org/doas.conf.5">doas</a>.</p></blockquote><ul><li>1.2. The config file</li></ul><blockquote><p>First you have to create a config and store it in /etc/nmctl.conf.<br
/> This file must respect few rules:<br
/> Each block must starts with a line having the following format: &#8221;&#8217;<-name->:<-interface->&#8221;&#8217;<br
/> Each following lines must start by at least one space. Those lines have more or less the same format as for hostname.if.<br
/> You have to create a block with the name &#8220;open&#8221;. This will be used to establish a connection to the Open Wifi around you (in restaurant for example)<br
/> The order of those elements is important. In case you use the -restart option, nmctl will try each of those network configs one after one until it can ping www.google.com. (if you wan to ping something else, you can change it in the python script if you want).<br
/> You can use external commands. Just preced them with the &#8220;!&#8221;.<br
/> You have macors. Macros allow you to perform some actions. The 2 currently implemented are &#8221;&#8217;<-nwid->&#8221;&#8217; and &#8221;&#8217;<-random
mac->&#8221;&#8217;.<br
/> You can use keywords. Currently the only one implemented is &#8220;dhcp&#8221;<br
/> Basically you can put all commands that nmctl will apply to the interface to which those commands are referring to. So, you will always have &#8220;ifconfig <-interface-> <-command
you type in the config file->&#8220;.<br
/> Check the manpage of ifconfig to see how flexible command is.<br
/> You have currently 2 macros:<br
/> &#8211; <-nwid-> which refers to the &#8220;nwid <-nwid
name->&#8221; when you select an Open Wifi with the -open option of nmctl.<br
/> &#8211; <-random
mac-> is a macro generating a random mac address. This is useful test a dhcp server for example.</p><p>The keyword &#8220;dhcp&#8221; will trigger a command like &#8220;dhclient <-interface->&#8220;.</p></blockquote><ul><li>1.3. Config file sample.</li></ul><blockquote><p>Let me show you one nmctl.conf example. It speaks by itself.</p></blockquote><p><code><p>&#35; the name open is required for Open wifi.<br
/> &#35; this is the interface that nmctl will take to establish a connection<br
/> &#35; We must put the macro <nwid>. This is where nmctl will put the nwid command<br
/> &#35; and the selected openwifi selected by the parameter --open</p><p>open:iwn0<br
/> !route flush<br
/> <nwid> -wpa<br
/> dhcp</p><p>cable:em0<br
/> !route flush<br
/> dhcp</p><p>lgg4:iwn0<br
/> !route flush<br
/> nwid LGG4s_8114 wpakey aanotherpassword<br
/> dhcp</p><p>home:iwn0<br
/> !route flush<br
/> nwid Linksys19594 wpakey apassword<br
/> dhcp</p><p>college:iwn0<br
/> !route flush<br
/> nwid john wpakey haahaaaguessme<br
/> dhcp</p><p>cable_fixip:em0<br
/> !route flush<br
/> inet 192.168.3.3 netmask 255.255.255.0<br
/> !route add -host default 192.168.3.1</p><p>&#35; with this network interface I'm using the macro <random
mac><br
/> &#35; which will do what you guess it will do :-)<br
/> cable_random:em0<br
/> !route flush<br
/> lladdr <random
mac><br
/> dhcp</p><p></code></p><blockquote><p>In this config we have several cable&#8217;s networks associated with my interface &#8220;em0&#8221; and several wifi networks associated with my wireless interface &#8220;iwn0&#8221;.<br
/> You see that you can switch from dhcp, to fixed IP and even you can play with the random mac address macro.<br
/> Thanks to the network called &#8220;open&#8221;, you can connect to any open wifi system. To do that, just type &#8221;&#8217; nmctl &#8211;open <-name
of the open wifi->&#8221;&#8217;<br
/> So, now, with just one command you can switch from one network configuration to an another one.<br
/> That&#8217;s become cool :-).</p></blockquote><ul><li><ol><li>Integration with openbox</li></ol></li></ul><blockquote><p>Thanks to the dynamic menu feature of oenbox[sic], you can have your different pre-defined networks under one click of your mouse.<br
/> For that, you just have to add, at the most appropriate place for you, the following code in your ./config/openbox/menu.xml</p></blockquote><p><code>&lt;menu id="network-menu" label="Network"&gt;<br
/> &lt;menu id="wifi-list" label="Wifi configured"  execute="doas /usr/local/bin/nmctl --list" /&gt;<br
/> &lt;menu id="wifi-scan" label="Wifi scan"  execute="doas /usr/local/bin/nmctl --scan" /&gt;<br
/> &lt;separator /&gt;</code></p><blockquote><p>In this case, you see the different networks as defined in the config file just above.</p></blockquote><ul><li><ol><li>Automatically identify your available connection and connect to it in one go</li></ol></li></ul><blockquote><p>But the most interesting part, is coming from a loop through all of your defined networks.<br
/> This loop is reachable via the -restart option.<br
/> Basically the idea is to loop from the first network config to the last and test a ping for each of them. Once the ping works, we break the loop and keep this setting.<br
/> Thus where ever you are, you just have to initiate a nmctl -restart and you will be connected to the network you have defined for this place. There is one small exception, the open-wifis. We do not include them in this loop exercise.<br
/> Thus the way you define your config file is important.<br
/> Since the network called &#8220;open&#8221; is dedicated to &#8220;open wifi&#8221;, it will not be part of this scan exercise. I propose you keep it at the first place.<br
/> Then, in my case, if my mobile, called lgg4, is open and visible by my laptop, I will connect it immediately.<br
/> Second, I check if my &#8220;home wifi&#8221; is visible.<br
/> Third, if I have a cable connected on my laptop, I&#8217;m using this connection and do a dhcp command.<br
/> Then, I check to see if my laptop is not viewing the &#8220;college&#8221; wifi.<br
/> ? and so on until a ping command works.<br
/> If you do not have a cable in your laptop and if none of your pre-defined wifi connections are visible, the scan will stop.</p></blockquote><ul><li>3.1 examples</li></ul><blockquote><p>No cable connected, no pre-defined wifi around me:</p></blockquote><p><code>t420:~$ time doas nmctl -r<br
/> nwids around you:  bbox2-d954<br
/> 0m02.97s real     0m00.08s user     0m00.11s system<br
/> t420:~$<br
/> t420:~$</code></p><blockquote><p>I&#8217;m at home and my wifi router is running:</p></blockquote><p><code><br
/> t420:~$ time doas nmctl -r<br
/> nwids around you:  Linksys19594 bbox2-d954<br
/> ifconfig em0 down: 0<br
/> default              fw                   done<br
/> fw                   00:22:4d:ac:30:fd    done<br
/> nas                  link#2               done<br
/> route flush: 0<br
/> ifconfig iwn0 nwid Linksys19594  ...: 0<br
/> iwn0: no link ........... sleeping<br
/> dhclient iwn0: 0<br
/> Done.<br
/> PING www.google.com (216.58.212.164): 56 data bytes<br
/> 64 bytes from 216.58.212.164: icmp_seq=0 ttl=52 time=12.758 ms</p><p>--- www.google.com ping statistics ---<br
/> 1 packets transmitted, 1 packets received, 0.0% packet loss<br
/> round-trip min/avg/max/std-dev = 12.758/12.758/12.758/0.000 ms<br
/> ping -c1 -w2 www.google.com: 0<br
/> 0m22.49s real     0m00.08s user     0m00.11s system<br
/> t420:~$<br
/> </code></p><blockquote><p>I&#8217;m at home but tethering is active on my mobile:</p></blockquote><p><code><br
/> t420:~$<br
/> t420:~$ time doas nmctl -r<br
/> nwids around you:  Linksys19594 bbox2-d954 LGG4s_8114<br
/> ifconfig em0 down: 0<br
/> default              fw                   done<br
/> fw                   00:22:4d:ac:30:fd    done<br
/> nas                  link#2               done<br
/> route flush: 0<br
/> ifconfig iwn0 nwid LGG4s_8114  ...: 0<br
/> iwn0: DHCPDISCOVER - interval 1<br
/> iwn0: DHCPDISCOVER - interval 2<br
/> iwn0: DHCPOFFER from 192.168.43.1 (a0:91:69:be:10:49)<br
/> iwn0: DHCPREQUEST to 255.255.255.255<br
/> iwn0: DHCPACK from 192.168.43.1 (a0:91:69:be:10:49)<br
/> iwn0: bound to 192.168.43.214 -- renewal in 1800 seconds<br
/> dhclient iwn0: 0<br
/> Done.<br
/> ping: Warning: www.google.com has multiple addresses; using 173.194.69.99<br
/> PING www.google.com (173.194.69.99): 56 data bytes<br
/> 64 bytes from 173.194.69.99: icmp_seq=0 ttl=43 time=42.863 ms</p><p>--- www.google.com ping statistics ---<br
/> 1 packets transmitted, 1 packets received, 0.0% packet loss<br
/> round-trip min/avg/max/std-dev = 42.863/42.863/42.863/0.000 ms<br
/> ping -c1 -w2 www.google.com: 0<br
/> 0m13.78s real     0m00.08s user     0m00.13s system<br
/> t420:~$<br
/> </code></p><blockquote><p>Same situation, but I cut the tethering just after the scan. Thus the dhcp command will not succeed.<br
/> We see that, after timeouts, nmctl see that the ping is failing (return code 1), thus he pass to the next possible pre-defined network.</p></blockquote><p><code><br
/> t420:~$ time doas nmctl -r<br
/> nwids around you:  Linksys19594 bbox2-d954 LGG4s_8114<br
/> ifconfig em0 down: 0<br
/> default              192.168.43.1         done<br
/> 192.168.43.1         a0:91:69:be:10:49    done<br
/> route flush: 0<br
/> ifconfig iwn0 nwid LGG4s_8114  ...: 0<br
/> iwn0: no link ........... sleeping<br
/> dhclient iwn0: 0<br
/> Done.<br
/> ping: no address associated with name<br
/> ping -c1 -w2 www.google.com: 1<br
/> ifconfig em0 down: 0<br
/> 192.168.43.1         link#2               done<br
/> route flush: 0<br
/> ifconfig iwn0 nwid Linksys19594  ...: 0<br
/> iwn0: DHCPREQUEST to 255.255.255.255<br
/> iwn0: DHCPACK from 192.168.3.1 (00:22:4d:ac:30:fd)<br
/> iwn0: bound to 192.168.3.16 -- renewal in 302400 seconds<br
/> dhclient iwn0: 0<br
/> Done.<br
/> PING www.google.com (216.58.212.164): 56 data bytes<br
/> 64 bytes from 216.58.212.164: icmp_seq=0 ttl=52 time=12.654 ms</p><p>--- www.google.com ping statistics ---<br
/> 1 packets transmitted, 1 packets received, 0.0% packet loss<br
/> round-trip min/avg/max/std-dev = 12.654/12.654/12.654/0.000 ms<br
/> ping -c1 -w2 www.google.com: 0<br
/> 3m34.85s real     0m00.17s user     0m00.20s system<br
/> t420:~$<br
/> </code></p><hr
/><h3><a
href="https://www.c0ffee.net/blog/openvpn-guide">OpenVPN Setup Guide for FreeBSD</a></h3><ul><li>OpenVPN Setup Guide<ul><li>Browse securely from anywhere using a personal VPN with OpenVPN, LDAP, FreeBSD, and PF.</li></ul></li></ul><blockquote><p>A VPN allows you to securely extend a private network over the internet via tunneling protocols and traffic encryption. For most people, a VPN offers two primary features: (1) the ability to access services on your local network over the internet, and (2) secure internet connectivity over an untrusted network. In this guide, I&#8217;ll describe how to set up a personal VPN using OpenVPN on FreeBSD. The configuration can use both SSL certificates and LDAP credentials for authentication. We&#8217;ll also be using the PF firewall to NAT traffic from our VPN out to the internet.<br
/> One important note about running your own VPN: since you are most likely hosting your server using a VPS or hosting provider, with a public IP address allocated specifically to you, your VPN will not give you any extra anonymity on the internet. If anything, you&#8217;ll be making yourself more of a target, since all your activity can be trivially traced back to your server&#8217;s IP address. So while your VPN will protect you from a snooping hacker on the free WiFi at Starbucks, it won&#8217;t protect you from a federal investigation.<br
/> This guide assumes you are running FreeBSD with the PF firewall. If you&#8217;re using a different Unix flavor, I&#8217;ll probably get you most of the way there—but you&#8217;ll be on your own when configuring your firewall and networking.<br
/> Finally, I&#8217;ve used example.com and a non-routable public IP address for all the examples in this guide. You&#8217;ll need to replace them with your own domain name and public IP address.</p></blockquote><hr
/><h2>Beastie Bits</h2><ul><li><a
href="https://www.youtube.com/channel/UCuQhwHMJ0yK2zlfyRr1XZ_Q/feed">BSDCan 2017 videos</a></li><li><a
href="https://www.openbsd.org/papers/eurobsdcon2017-device-drivers.pdf">Getting started with OpenBSD device driver development PDF</a></li><li><a
href="https://macfoo.wordpress.com/2017/10/27/aws-cloudwatch-logs-agent-for-freebsd/">AWS CloudWatch Logs agent for FreeBSD</a></li><li><a
href="https://www.freebsdfoundation.org/blog/november-2017-development-projects-update/">FreeBSD Foundation November 2017 Development Projects Update</a></li><li><a
href="https://fosdem.org/2018/schedule/track/bsd/">Schedule for the BSD Devroom at FOSDEM 2018</a></li></ul><hr
/><h2>Feedback/Questions</h2><ul><li>Matt &#8211; <a
href="http://dpaste.com/35VNXR5#wrap">The show and Cantrill</a></li><li>Paulo &#8211; <a
href="http://dpaste.com/17E9Z2W#wrap">FreeBSD Question</a></li><li>Steven &#8211; <a
href="http://dpaste.com/1N6F0TC#wrap">Virtualization under FreeBSD</a></li></ul><hr
/><ul><li>Send questions, comments, show ideas/topics, or stories you want mentioned on the show to <a
href="mailto:feedback@bsdnow.tv">feedback@bsdnow.tv</a></li></ul><hr
/></div><h3>Question? Comments? <a
href="/contact">Contact us here!</a></h3></div></div><div
id="contentright" class='col-md-4 col-lg-3'><div
id="sidebar"><div
id="logo" class='visible-md visible-lg'> <a
href="http://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img
src="http://www.jupiterbroadcasting.com/wp-content/themes/jb2014/images/logo.png" alt="Jupiter Broadcasting" /></a></div><div
class="widget"><h3 class='widget-title'>Related Posts</h3><div
class="widget-body" id="ratingsblock"><ul><li><a
href="http://www.jupiterbroadcasting.com/98861/freenas-mini-xl-bsd-now-137/" rel="bookmark" title="April 14, 2016">FreeNAS Mini XL | BSD Now 137</a></li><li><a
href="http://www.jupiterbroadcasting.com/61142/file-sharing-on-linux-howto-linux-4/" rel="bookmark" title="June 30, 2014">File sharing on Linux | HowTo Linux 4</a></li><li><a
href="http://www.jupiterbroadcasting.com/46957/meet-the-dockers-lup-16/" rel="bookmark" title="November 26, 2013">Meet the Dockers | LUP 16</a></li><li><a
href="http://www.jupiterbroadcasting.com/83242/bsd-after-midnight-bsd-now-92/" rel="bookmark" title="June 4, 2015">BSD After Midnight | BSD Now 92</a></li><li><a
href="http://www.jupiterbroadcasting.com/113981/tales-of-filesystems-techsnap-315/" rel="bookmark" title="April 18, 2017">Tales of FileSystems | TechSNAP 315</a></li></ul></div></div><div
class="widget"><h3 class="widget-title">Show Feeds and Social Networks</h3><div
class="widget-body"><div
id="social-widget"><ul
class='inline icons'><li> <a
target="_blank" href="http://ax.search.itunes.apple.com/WebObjects/MZSearch.woa/wa/search?entity=podcast&media=all&page=1&restrict=true&startIndex=0&term=Jupiter+Broadcasting" title="Subscribe in iTunes"> <img
src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-itunes.svg"/> </a></li><li> <a
target="_blank" href="https://plus.google.com/105226975130718072838" title="Circle us on Google+"> <img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-google-plus.svg" /> </a></li><li> <a
target="_blank" href="http://www.facebook.com/pages/Jupiter-Broadcasting/156241429615" title="Join our Facebook Page"> <img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-facebook.svg" /> </a></li><li> <a
target="_blank" href="https://twitter.com/jupitersignal" title="Follow us on Twitter"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-twitter.svg"/> </a></li><li> <a
target="_blank" href="http://bit.ly/jbsubreddits" title="Contribute on Reddit"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-reddit.svg"/> </a></li><li> <a
target="_blank" href="https://instagram.com/jupiterbroadcasting/" title="Follow us on Instragram"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-instagram.svg"/> </a></li><li> <a
target="_blank" href="https://www.youtube.com/user/jupiterbroadcasting" title="Subscribe on Youtube"> <img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-youtube.svg"/> </a></li></ul><script type="text/javascript">/*<![CDATA[*/function go(e){var destination=e.options[e.selectedIndex].value;if(destination&&destination!=0)window.open(destination,'_blank');}/*]]>*/</script><div
class="rss-container"> <img
class="rss-icon" src="http://jb7.cdn.scaleengine.net/wp-content/themes/jb2014/images/blue-rss.png"><h3>Subscribe via RSS:</h3> <select
onchange="go(this);"><option
value="0" selected="selected">Subscribe...</option><option
value="0">-- ALL SHOWS --</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=286971585">iTunes Large Video</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=280019325">iTunes MP3</option><option
value="http://feeds2.feedburner.com/AllJupiterVideos">Large Video RSS</option><option
value="http://feeds2.feedburner.com/JupiterBroadcasting">MP3 Audio RSS</option><option
value="0"></option><option
value="0">-- PODCAST NETWORKS --</option><option
value="http://landing.stitcher.com/?srcid=515">Stitcher</option><option
value="http://subscribe.getmiro.com/?url1=http%3A//feeds2.feedburner.com/JupiterBroadcastingVideos&trackback1=http%3A//www.miroguide.com/feeds/9506/subscribe-hit&section1=video">Miro</option><option
value="http://social.zune.net/redirect?type=podcastseries&id=66a6dec9-5ff2-45c6-99cd-0d74d4d02f5e&target=client">Zune</option><option
value="http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=286971585">iTunes</option><option
value="0"></option><option
value="0">-- ASK NOAH --</option><option
value="https://asknoah.fireside.fm/rss">MP3 Audio RSS</option><option
value="http://feedpress.me/AskNoahHD">HD Video RSS</option><option
value="https://itunes.apple.com/us/podcast/id1221193873">iTunes MP3 RSS</option><option
value="0"></option><option
value="0">-- BSD NOW! --</option><option
value="http://feeds.feedburner.com/BsdNowMobile">Mobile Video RSS</option><option
value="http://feeds.feedburner.com/BsdNowHd">HD Video RSS</option><option
value="http://feeds.feedburner.com/BsdNowMp3">MP3 Audio RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/bsdnowhd/feed">HD Torrent RSS</option><option
value="0"></option><option
value="0">-- CODER RADIO --</option><option
value="http://itunes.apple.com/us/podcast/coder-radio-mp3/id534941512">iTunes MP3</option><option
value="http://itunes.apple.com/us/podcast/coder-radio-video/id534941251">iTunes Video</option><option
value="http://feeds.feedburner.com/coderradiovideo">Video RSS</option><option
value="http://feeds.feedburner.com/coderradiomp3">MP3 Audio RSS</option><option
value="0"></option><option
value="0">-- LINUX ACTION NEWS! --</option><option
value="http://linuxactionnews.com/rss">MP3 Audio RSS</option><option
value="https://itunes.apple.com/us/podcast/linux-action-news/id1235143849">iTunes MP3</option><option
value="0"></option><option
value="0">-- LINUX UNPLUGGED --</option><option
value="http://feeds.feedburner.com/linuxunplugged">MP3 Audio RSS</option><option
value="https://itunes.apple.com/us/podcast/linux-unplugged-podcast/id687598126">iTunes Audio</option><option
value="http://feeds.feedburner.com/linuxunvid">Video RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/linuxunvid/feed">Torrent RSS</option><option
value="http://bitlove.org/jupiterbroadcasting/linuxunwebm/downloads.rss">WebM Torrent RSS</option><option
value="0"></option><option
value="0">-- TECHSNAP --</option><option
value="http://feeds.feedburner.com/techsnaphd">TechSNAP HD RSS</option><option
value="http://feeds.feedburner.com/techsnaplarge">TechSNAP Large RSS</option><option
value="http://feeds.feedburner.com/techsnapmobile">TechSNAP Mobile RSS</option><option
value="http://feeds.feedburner.com/techsnapmp3">TechSNAP MP3 RSS</option><option
value="http://itunes.apple.com/us/podcast/techsnap-in-hd/id433058842">TechSNAP iTunes HD</option><option
value="http://itunes.apple.com/us/podcast/techsnap-mobile-video/id433058959">TechSNAP iTunes Mobile</option><option
value="http://itunes.apple.com/us/podcast/techsnap-large-video/id433058851">TechSNAP iTunes Large</option><option
value="http://itunes.apple.com/us/podcast/techsnap-mp3/id433059024">TechSNAP iTunes MP3</option><option
value="0"></option><option
value="0">-- UNFILTER --</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterHD.xml">HD Video RSS</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterMob.xml">Mobile Video RSS</option><option
value="http://www.jupiterbroadcasting.com/feeds/unfilterMP3.xml">MP3 Audio RSS</option><option
value="http://ax.search.itunes.apple.com/WebObjects/MZSearch.woa/wa/search?entity=podcast&media=all&page=1&restrict=true&startIndex=0&term=Unfilter">unfilter on iTunes</option><option
value="0"></option><option
value="0">-- USER ERROR --</option><option
value="https://feedpress.me/usererror">MP3 Audio</option><option
value="https://feedpress.me/uevideo">Video</option><option
value="https://itunes.apple.com/us/podcast/user-error-podcast/id1145648639">iTunes Audio</option><option
value="0"></option> </select></div></div></div></div><div
class="widget"><h3 class="widget-title">Support Jupiter Broadcasting</h3><div
class="widget-body"><div
class='support'><ul
class='inline icons'><li><a
href='https://www.patreon.com/jupitersignal' title="Jupiter Signal" target="_blank"><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/Patreon_logo_kit/Logomark/Color on White/Patreon logomark (color on white).png"/></a></li><li
style="margin-right: 20px;"><a
href='https://www.patreon.com/unfilter' title="Unfilter" target="_blank"><img
src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/Patreon_logo_kit/Logomark/Color on White/Patreon logomark (color on white).png"/></a></li><li><form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"> <input
name="cmd" type="hidden" value="_s-xclick" /> <input
name="hosted_button_id" type="hidden" value="M5RAZYK4YW9RG" /> <input
alt="PayPal - The safer, easier way to pay online!" name="submit" src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/paypal5.png" type="image" /></form></li><li><form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"> <input
name="cmd" type="hidden" value="_s-xclick" /> <input
name="hosted_button_id" type="hidden" value="JT5XM8LDZ5UMQ" /> <input
alt="PayPal - The safer, easier way to pay online!" name="submit" src="http://jb6.cdn.scaleengine.net/wp-content/themes/jb2014/images/paypal10.png" type="image" /></form></li></ul></div></div></div><div
class="widget"><h3 class="widget-title">JB Stickers!!</h3><div
class="widget-body"><div
class="textwidget"><div
style="text-align: center;"><a
href="/stickers"><img
src="http://jb5.cdn.scaleengine.net/wp-content/themes/jb2014/images/stickers/JupiterBroadcasting.png"></a><p>Jupiter Broadcasting stickers are now available!<br><a
href="/stickers">Click here</a> to get yours now!</p></div></div></div></div><div
class="widget"><h3 class="widget-title">Calendar</h3><div
class="widget-body"><script src="http://cdnjs.cloudflare.com/ajax/libs/jstimezonedetect/1.0.4/jstz.min.js"></script><script>/*<![CDATA[*/var calendarBase="http://www.google.com/calendar/embed?showTitle=0&showNav=0&showPrint=0&showTabs=0&showCalendars=0&mode=AGENDA&height=240&wkst=1&bgcolor=%23FFFFFF&src=jalb5frk4cunnaedbfemuqbhv4%40group.calendar.google.com&color=%235229A3&"
function updateCalendar()
{e=document.getElementById('ctz');document.getElementById("calendar").src=calendarBase+"ctz="+e.options[e.selectedIndex].value;}/*]]>*/</script><div
id="calendar-container" class='responsive-object-wrapper'></div> <select
name="ctz" id="ctz" onchange="updateCalendar()" class="full-width-field" style="max-width: 100%"><option>-- Select Your Timezone --</option><option
value="Pacific/Midway">(GMT-11:00) Midway</option><option
value="Pacific/Niue">(GMT-11:00) Niue</option><option
value="Pacific/Pago_Pago">(GMT-11:00) Pago Pago</option><option
value="Pacific/Honolulu">(GMT-10:00) Hawaii Time</option><option
value="Pacific/Johnston">(GMT-10:00) Johnston</option><option
value="Pacific/Rarotonga">(GMT-10:00) Rarotonga</option><option
value="Pacific/Tahiti">(GMT-10:00) Tahiti</option><option
value="Pacific/Marquesas">(GMT-09:30) Marquesas</option><option
value="America/Anchorage">(GMT-09:00) Alaska Time</option><option
value="Pacific/Gambier">(GMT-09:00) Gambier</option><option
value="America/Los_Angeles">(GMT-08:00) Pacific Time</option><option
value="America/Tijuana">(GMT-08:00) Pacific Time - Tijuana</option><option
value="America/Vancouver">(GMT-08:00) Pacific Time - Vancouver</option><option
value="America/Whitehorse">(GMT-08:00) Pacific Time - Whitehorse</option><option
value="Pacific/Pitcairn">(GMT-08:00) Pitcairn</option><option
value="America/Dawson_Creek">(GMT-07:00) Mountain Time - Dawson Creek</option><option
value="America/Denver">(GMT-07:00) Mountain Time</option><option
value="America/Edmonton">(GMT-07:00) Mountain Time - Edmonton</option><option
value="America/Hermosillo">(GMT-07:00) Mountain Time - Hermosillo</option><option
value="America/Mazatlan">(GMT-07:00) Mountain Time - Chihuahua, Mazatlan</option><option
value="America/Phoenix">(GMT-07:00) Mountain Time - Arizona</option><option
value="America/Yellowknife">(GMT-07:00) Mountain Time - Yellowknife</option><option
value="America/Belize">(GMT-06:00) Belize</option><option
value="America/Chicago">(GMT-06:00) Central Time</option><option
value="America/Costa_Rica">(GMT-06:00) Costa Rica</option><option
value="America/El_Salvador">(GMT-06:00) El Salvador</option><option
value="America/Guatemala">(GMT-06:00) Guatemala</option><option
value="America/Managua">(GMT-06:00) Managua</option><option
value="America/Mexico_City">(GMT-06:00) Central Time - Mexico City</option><option
value="America/Regina">(GMT-06:00) Central Time - Regina</option><option
value="America/Tegucigalpa">(GMT-06:00) Central Time - Tegucigalpa</option><option
value="America/Winnipeg">(GMT-06:00) Central Time - Winnipeg</option><option
value="Pacific/Easter">(GMT-06:00) Easter Island</option><option
value="Pacific/Galapagos">(GMT-06:00) Galapagos</option><option
value="America/Bogota">(GMT-05:00) Bogota</option><option
value="America/Cayman">(GMT-05:00) Cayman</option><option
value="America/Grand_Turk">(GMT-05:00) Grand Turk</option><option
value="America/Guayaquil">(GMT-05:00) Guayaquil</option><option
value="America/Havana">(GMT-05:00) Havana</option><option
value="America/Iqaluit">(GMT-05:00) Eastern Time - Iqaluit</option><option
value="America/Jamaica">(GMT-05:00) Jamaica</option><option
value="America/Lima">(GMT-05:00) Lima</option><option
value="America/Montreal">(GMT-05:00) Eastern Time - Montreal</option><option
value="America/Nassau">(GMT-05:00) Nassau</option><option
value="America/New_York">(GMT-05:00) Eastern Time</option><option
value="America/Panama">(GMT-05:00) Panama</option><option
value="America/Port-au-Prince">(GMT-05:00) Port-au-Prince</option><option
value="America/Toronto">(GMT-05:00) Eastern Time - Toronto</option><option
value="America/Caracas">(GMT-04:30) Caracas</option><option
value="America/Anguilla">(GMT-04:00) Anguilla</option><option
value="America/Antigua">(GMT-04:00) Antigua</option><option
value="America/Aruba">(GMT-04:00) Aruba</option><option
value="America/Asuncion">(GMT-04:00) Asuncion</option><option
value="America/Barbados">(GMT-04:00) Barbados</option><option
value="America/Boa_Vista">(GMT-04:00) Boa Vista</option><option
value="America/Campo_Grande">(GMT-04:00) Campo Grande</option><option
value="America/Cuiaba">(GMT-04:00) Cuiaba</option><option
value="America/Curacao">(GMT-04:00) Curacao</option><option
value="America/Dominica">(GMT-04:00) Dominica</option><option
value="America/Grenada">(GMT-04:00) Grenada</option><option
value="America/Guadeloupe">(GMT-04:00) Guadeloupe</option><option
value="America/Guyana">(GMT-04:00) Guyana</option><option
value="America/Halifax">(GMT-04:00) Atlantic Time - Halifax</option><option
value="America/La_Paz">(GMT-04:00) La Paz</option><option
value="America/Manaus">(GMT-04:00) Manaus</option><option
value="America/Martinique">(GMT-04:00) Martinique</option><option
value="America/Montserrat">(GMT-04:00) Montserrat</option><option
value="America/Port_of_Spain">(GMT-04:00) Port of Spain</option><option
value="America/Porto_Velho">(GMT-04:00) Porto Velho</option><option
value="America/Puerto_Rico">(GMT-04:00) Puerto Rico</option><option
value="America/Rio_Branco">(GMT-04:00) Rio Branco</option><option
value="America/Santiago">(GMT-04:00) Santiago</option><option
value="America/Santo_Domingo">(GMT-04:00) Santo Domingo</option><option
value="America/St_Kitts">(GMT-04:00) St. Kitts</option><option
value="America/St_Lucia">(GMT-04:00) St. Lucia</option><option
value="America/St_Thomas">(GMT-04:00) St. Thomas</option><option
value="America/St_Vincent">(GMT-04:00) St. Vincent</option><option
value="America/Thule">(GMT-04:00) Thule</option><option
value="America/Tortola">(GMT-04:00) Tortola</option><option
value="Antarctica/Palmer">(GMT-04:00) Palmer</option><option
value="Atlantic/Bermuda">(GMT-04:00) Bermuda</option><option
value="America/St_Johns">(GMT-03:30) Newfoundland Time - St. Johns</option><option
value="America/Araguaina">(GMT-03:00) Araguaina</option><option
value="America/Argentina/Buenos_Aires">(GMT-03:00) Buenos Aires</option><option
value="America/Bahia">(GMT-03:00) Salvador</option><option
value="America/Belem">(GMT-03:00) Belem</option><option
value="America/Cayenne">(GMT-03:00) Cayenne</option><option
value="America/Fortaleza">(GMT-03:00) Fortaleza</option><option
value="America/Godthab">(GMT-03:00) Godthab</option><option
value="America/Maceio">(GMT-03:00) Maceio</option><option
value="America/Miquelon">(GMT-03:00) Miquelon</option><option
value="America/Montevideo">(GMT-03:00) Montevideo</option><option
value="America/Paramaribo">(GMT-03:00) Paramaribo</option><option
value="America/Recife">(GMT-03:00) Recife</option><option
value="America/Sao_Paulo">(GMT-03:00) Sao Paulo</option><option
value="Antarctica/Rothera">(GMT-03:00) Rothera</option><option
value="Atlantic/Stanley">(GMT-03:00) Stanley</option><option
value="America/Noronha">(GMT-02:00) Noronha</option><option
value="Atlantic/South_Georgia">(GMT-02:00) South Georgia</option><option
value="America/Scoresbysund">(GMT-01:00) Scoresbysund</option><option
value="Atlantic/Azores">(GMT-01:00) Azores</option><option
value="Atlantic/Cape_Verde">(GMT-01:00) Cape Verde</option><option
value="Africa/Abidjan">(GMT+00:00) Abidjan</option><option
value="Africa/Accra">(GMT+00:00) Accra</option><option
value="Africa/Bamako">(GMT+00:00) Bamako</option><option
value="Africa/Banjul">(GMT+00:00) Banjul</option><option
value="Africa/Bissau">(GMT+00:00) Bissau</option><option
value="Africa/Casablanca">(GMT+00:00) Casablanca</option><option
value="Africa/Conakry">(GMT+00:00) Conakry</option><option
value="Africa/Dakar">(GMT+00:00) Dakar</option><option
value="Africa/El_Aaiun">(GMT+00:00) El Aaiun</option><option
value="Africa/Freetown">(GMT+00:00) Freetown</option><option
value="Africa/Lome">(GMT+00:00) Lome</option><option
value="Africa/Monrovia">(GMT+00:00) Monrovia</option><option
value="Africa/Nouakchott">(GMT+00:00) Nouakchott</option><option
value="Africa/Ouagadougou">(GMT+00:00) Ouagadougou</option><option
value="Africa/Sao_Tome">(GMT+00:00) Sao Tome</option><option
value="America/Danmarkshavn">(GMT+00:00) Danmarkshavn</option><option
value="Atlantic/Canary">(GMT+00:00) Canary Islands</option><option
value="Atlantic/Faroe">(GMT+00:00) Faeroe</option><option
value="Atlantic/Reykjavik">(GMT+00:00) Reykjavik</option><option
value="Atlantic/St_Helena">(GMT+00:00) St Helena</option><option
value="Etc/GMT">(GMT+00:00) GMT (no daylight saving)</option><option
value="Europe/Dublin">(GMT+00:00) Dublin</option><option
value="Europe/Lisbon">(GMT+00:00) Lisbon</option><option
value="Europe/London">(GMT+00:00) London</option><option
value="Africa/Algiers">(GMT+01:00) Algiers</option><option
value="Africa/Bangui">(GMT+01:00) Bangui</option><option
value="Africa/Brazzaville">(GMT+01:00) Brazzaville</option><option
value="Africa/Ceuta">(GMT+01:00) Ceuta</option><option
value="Africa/Douala">(GMT+01:00) Douala</option><option
value="Africa/Kinshasa">(GMT+01:00) Kinshasa</option><option
value="Africa/Lagos">(GMT+01:00) Lagos</option><option
value="Africa/Libreville">(GMT+01:00) Libreville</option><option
value="Africa/Luanda">(GMT+01:00) Luanda</option><option
value="Africa/Malabo">(GMT+01:00) Malabo</option><option
value="Africa/Ndjamena">(GMT+01:00) Ndjamena</option><option
value="Africa/Niamey">(GMT+01:00) Niamey</option><option
value="Africa/Porto-Novo">(GMT+01:00) Porto-Novo</option><option
value="Africa/Tripoli">(GMT+01:00) Tripoli</option><option
value="Africa/Tunis">(GMT+01:00) Tunis</option><option
value="Africa/Windhoek">(GMT+01:00) Windhoek</option><option
value="Europe/Amsterdam">(GMT+01:00) Amsterdam</option><option
value="Europe/Andorra">(GMT+01:00) Andorra</option><option
value="Europe/Belgrade">(GMT+01:00) Central European Time - Belgrade</option><option
value="Europe/Berlin">(GMT+01:00) Berlin</option><option
value="Europe/Brussels">(GMT+01:00) Brussels</option><option
value="Europe/Budapest">(GMT+01:00) Budapest</option><option
value="Europe/Copenhagen">(GMT+01:00) Copenhagen</option><option
value="Europe/Gibraltar">(GMT+01:00) Gibraltar</option><option
value="Europe/Luxembourg">(GMT+01:00) Luxembourg</option><option
value="Europe/Madrid">(GMT+01:00) Madrid</option><option
value="Europe/Malta">(GMT+01:00) Malta</option><option
value="Europe/Monaco">(GMT+01:00) Monaco</option><option
value="Europe/Oslo">(GMT+01:00) Oslo</option><option
value="Europe/Paris">(GMT+01:00) Paris</option><option
value="Europe/Prague">(GMT+01:00) Central European Time - Prague</option><option
value="Europe/Rome">(GMT+01:00) Rome</option><option
value="Europe/Stockholm">(GMT+01:00) Stockholm</option><option
value="Europe/Tirane">(GMT+01:00) Tirane</option><option
value="Europe/Vaduz">(GMT+01:00) Vaduz</option><option
value="Europe/Vienna">(GMT+01:00) Vienna</option><option
value="Europe/Warsaw">(GMT+01:00) Warsaw</option><option
value="Europe/Zurich">(GMT+01:00) Zurich</option><option
value="Africa/Blantyre">(GMT+02:00) Blantyre</option><option
value="Africa/Bujumbura">(GMT+02:00) Bujumbura</option><option
value="Africa/Cairo">(GMT+02:00) Cairo</option><option
value="Africa/Gaborone">(GMT+02:00) Gaborone</option><option
value="Africa/Harare">(GMT+02:00) Harare</option><option
value="Africa/Johannesburg">(GMT+02:00) Johannesburg</option><option
value="Africa/Kigali">(GMT+02:00) Kigali</option><option
value="Africa/Lubumbashi">(GMT+02:00) Lubumbashi</option><option
value="Africa/Lusaka">(GMT+02:00) Lusaka</option><option
value="Africa/Maputo">(GMT+02:00) Maputo</option><option
value="Africa/Maseru">(GMT+02:00) Maseru</option><option
value="Africa/Mbabane">(GMT+02:00) Mbabane</option><option
value="Asia/Amman">(GMT+02:00) Amman</option><option
value="Asia/Beirut">(GMT+02:00) Beirut</option><option
value="Asia/Damascus">(GMT+02:00) Damascus</option><option
value="Asia/Gaza">(GMT+02:00) Gaza</option><option
value="Asia/Jerusalem">(GMT+02:00) Jerusalem</option><option
value="Asia/Nicosia">(GMT+02:00) Nicosia</option><option
value="Europe/Athens">(GMT+02:00) Athens</option><option
value="Europe/Bucharest">(GMT+02:00) Bucharest</option><option
value="Europe/Chisinau">(GMT+02:00) Chisinau</option><option
value="Europe/Helsinki">(GMT+02:00) Helsinki</option><option
value="Europe/Istanbul">(GMT+02:00) Istanbul</option><option
value="Europe/Kiev">(GMT+02:00) Kiev</option><option
value="Europe/Riga">(GMT+02:00) Riga</option><option
value="Europe/Sofia">(GMT+02:00) Sofia</option><option
value="Europe/Tallinn">(GMT+02:00) Tallinn</option><option
value="Europe/Vilnius">(GMT+02:00) Vilnius</option><option
value="Africa/Addis_Ababa">(GMT+03:00) Addis Ababa</option><option
value="Africa/Asmara">(GMT+03:00) Asmera</option><option
value="Africa/Dar_es_Salaam">(GMT+03:00) Dar es Salaam</option><option
value="Africa/Djibouti">(GMT+03:00) Djibouti</option><option
value="Africa/Kampala">(GMT+03:00) Kampala</option><option
value="Africa/Khartoum">(GMT+03:00) Khartoum</option><option
value="Africa/Mogadishu">(GMT+03:00) Mogadishu</option><option
value="Africa/Nairobi">(GMT+03:00) Nairobi</option><option
value="Antarctica/Syowa">(GMT+03:00) Syowa</option><option
value="Asia/Aden">(GMT+03:00) Aden</option><option
value="Asia/Baghdad">(GMT+03:00) Baghdad</option><option
value="Asia/Bahrain">(GMT+03:00) Bahrain</option><option
value="Asia/Kuwait">(GMT+03:00) Kuwait</option><option
value="Asia/Qatar">(GMT+03:00) Qatar</option><option
value="Asia/Riyadh">(GMT+03:00) Riyadh</option><option
value="Europe/Kaliningrad">(GMT+03:00) Moscow-01 - Kaliningrad</option><option
value="Europe/Minsk">(GMT+03:00) Minsk</option><option
value="Indian/Antananarivo">(GMT+03:00) Antananarivo</option><option
value="Indian/Comoro">(GMT+03:00) Comoro</option><option
value="Indian/Mayotte">(GMT+03:00) Mayotte</option><option
value="Asia/Tehran">(GMT+03:30) Tehran</option><option
value="Asia/Baku">(GMT+04:00) Baku</option><option
value="Asia/Dubai">(GMT+04:00) Dubai</option><option
value="Asia/Muscat">(GMT+04:00) Muscat</option><option
value="Asia/Tbilisi">(GMT+04:00) Tbilisi</option><option
value="Asia/Yerevan">(GMT+04:00) Yerevan</option><option
value="Europe/Moscow">(GMT+04:00) Moscow+00</option><option
value="Europe/Samara">(GMT+04:00) Moscow+00 - Samara</option><option
value="Indian/Mahe">(GMT+04:00) Mahe</option><option
value="Indian/Mauritius">(GMT+04:00) Mauritius</option><option
value="Indian/Reunion">(GMT+04:00) Reunion</option><option
value="Asia/Kabul">(GMT+04:30) Kabul</option><option
value="Antarctica/Mawson">(GMT+05:00) Mawson</option><option
value="Asia/Aqtau">(GMT+05:00) Aqtau</option><option
value="Asia/Aqtobe">(GMT+05:00) Aqtobe</option><option
value="Asia/Ashgabat">(GMT+05:00) Ashgabat</option><option
value="Asia/Dushanbe">(GMT+05:00) Dushanbe</option><option
value="Asia/Karachi">(GMT+05:00) Karachi</option><option
value="Asia/Tashkent">(GMT+05:00) Tashkent</option><option
value="Indian/Kerguelen">(GMT+05:00) Kerguelen</option><option
value="Indian/Maldives">(GMT+05:00) Maldives</option><option
value="Asia/Calcutta">(GMT+05:30) India Standard Time</option><option
value="Asia/Colombo">(GMT+05:30) Colombo</option><option
value="Asia/Katmandu">(GMT+05:45) Katmandu</option><option
value="Antarctica/Vostok">(GMT+06:00) Vostok</option><option
value="Asia/Almaty">(GMT+06:00) Almaty</option><option
value="Asia/Bishkek">(GMT+06:00) Bishkek</option><option
value="Asia/Dhaka">(GMT+06:00) Dhaka</option><option
value="Asia/Thimphu">(GMT+06:00) Thimphu</option><option
value="Asia/Yekaterinburg">(GMT+06:00) Moscow+02 - Yekaterinburg</option><option
value="Indian/Chagos">(GMT+06:00) Chagos</option><option
value="Asia/Rangoon">(GMT+06:30) Rangoon</option><option
value="Indian/Cocos">(GMT+06:30) Cocos</option><option
value="Antarctica/Davis">(GMT+07:00) Davis</option><option
value="Asia/Bangkok">(GMT+07:00) Bangkok</option><option
value="Asia/Hovd">(GMT+07:00) Hovd</option><option
value="Asia/Jakarta">(GMT+07:00) Jakarta</option><option
value="Asia/Omsk">(GMT+07:00) Moscow+03 - Omsk, Novosibirsk</option><option
value="Asia/Phnom_Penh">(GMT+07:00) Phnom Penh</option><option
value="Asia/Saigon">(GMT+07:00) Hanoi</option><option
value="Asia/Vientiane">(GMT+07:00) Vientiane</option><option
value="Indian/Christmas">(GMT+07:00) Christmas</option><option
value="Antarctica/Casey">(GMT+08:00) Casey</option><option
value="Asia/Brunei">(GMT+08:00) Brunei</option><option
value="Asia/Choibalsan">(GMT+08:00) Choibalsan</option><option
value="Asia/Hong_Kong">(GMT+08:00) Hong Kong</option><option
value="Asia/Krasnoyarsk">(GMT+08:00) Moscow+04 - Krasnoyarsk</option><option
value="Asia/Kuala_Lumpur">(GMT+08:00) Kuala Lumpur</option><option
value="Asia/Macau">(GMT+08:00) Macau</option><option
value="Asia/Makassar">(GMT+08:00) Makassar</option><option
value="Asia/Manila">(GMT+08:00) Manila</option><option
value="Asia/Shanghai">(GMT+08:00) China Time - Beijing</option><option
value="Asia/Singapore">(GMT+08:00) Singapore</option><option
value="Asia/Taipei">(GMT+08:00) Taipei</option><option
value="Asia/Ulaanbaatar">(GMT+08:00) Ulaanbaatar</option><option
value="Australia/Perth">(GMT+08:00) Western Time - Perth</option><option
value="Asia/Dili">(GMT+09:00) Dili</option><option
value="Asia/Irkutsk">(GMT+09:00) Moscow+05 - Irkutsk</option><option
value="Asia/Jayapura">(GMT+09:00) Jayapura</option><option
value="Asia/Pyongyang">(GMT+09:00) Pyongyang</option><option
value="Asia/Seoul">(GMT+09:00) Seoul</option><option
value="Asia/Tokyo">(GMT+09:00) Tokyo</option><option
value="Pacific/Palau">(GMT+09:00) Palau</option><option
value="Australia/Adelaide">(GMT+09:30) Central Time - Adelaide</option><option
value="Australia/Darwin">(GMT+09:30) Central Time - Darwin</option><option
value="Antarctica/DumontDUrville">(GMT+10:00) Dumont D&#39;Urville</option><option
value="Asia/Yakutsk">(GMT+10:00) Moscow+06 - Yakutsk</option><option
value="Australia/Brisbane">(GMT+10:00) Eastern Time - Brisbane</option><option
value="Australia/Hobart">(GMT+10:00) Eastern Time - Hobart</option><option
value="Australia/Sydney">(GMT+10:00) Eastern Time - Melbourne, Sydney</option><option
value="Pacific/Guam">(GMT+10:00) Guam</option><option
value="Pacific/Port_Moresby">(GMT+10:00) Port Moresby</option><option
value="Pacific/Saipan">(GMT+10:00) Saipan</option><option
value="Pacific/Truk">(GMT+10:00) Truk</option><option
value="Asia/Vladivostok">(GMT+11:00) Moscow+07 - Yuzhno-Sakhalinsk</option><option
value="Pacific/Efate">(GMT+11:00) Efate</option><option
value="Pacific/Guadalcanal">(GMT+11:00) Guadalcanal</option><option
value="Pacific/Kosrae">(GMT+11:00) Kosrae</option><option
value="Pacific/Noumea">(GMT+11:00) Noumea</option><option
value="Pacific/Ponape">(GMT+11:00) Ponape</option><option
value="Pacific/Norfolk">(GMT+11:30) Norfolk</option><option
value="Asia/Kamchatka">(GMT+12:00) Moscow+08 - Petropavlovsk-Kamchatskiy</option><option
value="Asia/Magadan">(GMT+12:00) Moscow+08 - Magadan</option><option
value="Pacific/Auckland">(GMT+12:00) Auckland</option><option
value="Pacific/Fiji">(GMT+12:00) Fiji</option><option
value="Pacific/Funafuti">(GMT+12:00) Funafuti</option><option
value="Pacific/Kwajalein">(GMT+12:00) Kwajalein</option><option
value="Pacific/Majuro">(GMT+12:00) Majuro</option><option
value="Pacific/Nauru">(GMT+12:00) Nauru</option><option
value="Pacific/Tarawa">(GMT+12:00) Tarawa</option><option
value="Pacific/Wake">(GMT+12:00) Wake</option><option
value="Pacific/Wallis">(GMT+12:00) Wallis</option><option
value="Pacific/Apia">(GMT+13:00) Apia</option><option
value="Pacific/Enderbury">(GMT+13:00) Enderbury</option><option
value="Pacific/Fakaofo">(GMT+13:00) Fakaofo</option><option
value="Pacific/Tongatapu">(GMT+13:00) Tongatapu</option><option
value="Pacific/Kiritimati">(GMT+14:00) Kiritimati</option> </select> <script>var tz=jstz.determine();var tzname=encodeURIComponent(tz.name());var calendar=document.createElement("iframe");calendar.frameBorder=0;calendar.width="100%";calendar.height="240px";calendar.id="calendar";calendar.src=calendarBase+"ctz="+tzname
calendar.setAttribute("src",calendar.src);document.getElementById("calendar-container").appendChild(calendar);</script></div></div></div></div></div></div><div
id="footer-spacer"></div><div
id="footer"><div
class="container"><div
class="afflinks"><p><strong>Support Jupiter Broadcasting while shopping at:</strong></p><p> <a
href="http://www.amazon.co.uk/?tag=jupitebroa062-21">Amazon UK</a> <a
href="http://rover.ebay.com/rover/1/711-53200-19255-0/1?icep_ff3=1&pub=5575027880&toolid=10001&campid=5337188513&customid=&ipn=psmain&icep_vectorid=229466&kwid=902099&mtid=824&kw=lg">eBay</a> <a
href="http://www.kqzyfj.com/click-4897915-10784884">Think Geek</a> <a
href="http://www.woot.com/?utm_campaign=Commission+Junction+-+10848750&utm_source=Commission+Junction+Publisher+-+4897915&utm_medium=affiliate+-+Woot%21+Logo">Woot!</a> <a
href="http://www.dpbolvw.net/click-4897915-10298646">Audible</a> <a
href="http://zfer.us/iln1s">Code School</a> <a
href="http://www.anrdoezrs.net/click-4897915-10606699">NewEgg CA</a></p></div><div
class="licensecopy"><p
class="license">Our shows are licensed under <a
href="http://creativecommons.org/licenses/by-sa/4.0/"><strong>Creative Commons BY-SA 4.0</strong></a></p><p
class="copyright">2017 JupiterBroadcasting.com - All Rights Reserved</p></div></div></div><script type='text/javascript' src='//vjs.zencdn.net/4.12/video.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/themes/jb2014/scripts/video-quality-selector.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/themes/jb2014/scripts/videojs-seek.min.js'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-content/plugins//automatic-video-posts/js/scripts.js?ver=1.0'></script><script type='text/javascript' src='http://jb2.cdn.scaleengine.net/wp-includes/js/wp-embed.min.js?ver=4.5.11'></script><script>/*<![CDATA[*/jQuery(function($){$('#contentleft').on('click','.loadmore',function(e){e.preventDefault();var $this=$(this);if(!$this.hasClass('loading')){$this.addClass('loading');$this.html('<i class="fa fa-fw fa-spinner fa-spin"></i> Loading...');$.get(this.href).done(function(response){$(response).find('.videoitem').appendTo('#videogallery');$this.replaceWith($(response).find('.loadmore').get(0));});}});});/*]]>*/</script><script type="text/javascript">videojs('video').ready(function(){var myPlayer=this,id=myPlayer.id();var aspectRatio=264/640;function resizeVideoJS(){var width=document.getElementById(id).parentElement.offsetWidth;myPlayer.width(width).height(width*aspectRatio);}
resizeVideoJS();window.onresize=resizeVideoJS;});</script>