
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" prefix="og: http://ogp.me/ns#" lang="en-US">

<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<title>Mars Goes to Shell | LINUX Unplugged 406 | Jupiter Broadcasting</title>

<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="alternate" type="application/rss+xml" title="Jupiter Broadcasting RSS Feed" href="https://www.jupiterbroadcasting.com/feed/" />
<link rel="pingback" href="https://www.jupiterbroadcasting.com/xmlrpc.php" />

<meta property="og:image" content="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658.png"/>
<link rel="image_src" href="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658.png"/>
<link rel="shortcut icon" href="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/favicon.ico" type="image/x-icon">
<link rel="icon" href="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/favicon.ico" type="image/x-icon">

<!-- All In One SEO Pack 3.7.0[323,423] -->
<meta name="description"  content="Tim Canham, Mars Helicopter Operations Lead at NASA&#039;s JPL joins us again to share technical details you&#039;ve never heard about the Ingenuity Linux Copter on Mars. And the challenges they had to work around to achieve their five successful flights." />

<meta name="keywords"  content="1password,activitypub,android,appimage,dart,decentralized,electron,f prime,f-droid,federation,fediverse,ffmpeg,finamp,helicopter,ios,jpl,jupiter broadcasting,linux apps,linux in space,linux podcast,linuxcopter,live stream,mars 2020,mars rover,music player,nasa,open source,p2p,password manager,peer-to-peer,peertube,perseverance,plexamp,radio,react,rotocopter,rust,self hosted,self-hosting,serial,space,tim canham,typescript,uart,youtube,zigbee,featured,linux unplugged,video" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.jupiterbroadcasting.com/#organization","url":"https://www.jupiterbroadcasting.com/","name":"Jupiter Broadcasting","sameAs":[]},{"@type":"WebSite","@id":"https://www.jupiterbroadcasting.com/#website","url":"https://www.jupiterbroadcasting.com/","name":"Jupiter Broadcasting","publisher":{"@id":"https://www.jupiterbroadcasting.com/#organization"}},{"@type":"WebPage","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#webpage","url":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/","inLanguage":"en-US","name":"Mars Goes to Shell | LINUX Unplugged 406","isPartOf":{"@id":"https://www.jupiterbroadcasting.com/#website"},"breadcrumb":{"@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#breadcrumblist"},"description":"Tim Canham, Mars Helicopter Operations Lead at NASA&#039;s JPL joins us again to share technical details you&#039;ve never heard about the Ingenuity Linux Copter on Mars. And the challenges they had to work around to achieve their five successful flights.","image":{"@type":"ImageObject","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#primaryimage","url":"https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658.png","width":729,"height":409},"primaryImageOfPage":{"@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#primaryimage"},"datePublished":"2021-05-19T00:45:00-08:00","dateModified":"2021-05-19T01:07:50-08:00"},{"@type":"Article","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#article","isPartOf":{"@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#webpage"},"author":{"@id":"https://www.jupiterbroadcasting.com/author/wes/#author"},"headline":"Mars Goes to Shell | LINUX Unplugged 406","datePublished":"2021-05-19T00:45:00-08:00","dateModified":"2021-05-19T01:07:50-08:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#webpage"},"publisher":{"@id":"https://www.jupiterbroadcasting.com/#organization"},"articleSection":"Featured, LINUX Unplugged, Video, 1Password, activitypub, android, AppImage, Dart, decentralized, Electron, f prime, F-Droid, Federation, fediverse, FFMpeg, finamp, helicopter, iOS, jpl, Jupiter Broadcasting, Linux Apps, linux in space, Linux Podcast, linuxcopter, live stream, mars 2020, Mars rover, music player, NASA, open source, p2p, Password Manager, Peer-to-Peer, PeerTube, perseverance, plexamp, Radio, React, rotocopter, Rust, self hosted, self-hosting, Serial, space, tim canham, TypeScript, uart, YouTube, ZigBee","image":{"@type":"ImageObject","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#primaryimage","url":"https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658.png","width":729,"height":409}},{"@type":"Person","@id":"https://www.jupiterbroadcasting.com/author/wes/#author","name":"Wes Payne","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.jupiterbroadcasting.com/#personlogo","url":"https://secure.gravatar.com/avatar/f2fcddb941dcf0276ab31cf9a45b5c6f?s=96&d=mm&r=g","width":96,"height":96,"caption":"Wes Payne"}},{"@type":"BreadcrumbList","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.jupiterbroadcasting.com/","url":"https://www.jupiterbroadcasting.com/","name":"Jupiter Broadcasting"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/","url":"https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/","name":"Mars Goes to Shell | LINUX Unplugged 406"}}]}]}</script>
<link rel="canonical" href="https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//vjs.zencdn.net' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//proxy.radiojar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.jupiterbroadcasting.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='video-js-css-css'  href='//vjs.zencdn.net/4.12/video-js.css' type='text/css' media='all' />
<link rel='stylesheet' id='video-quality-selector-css-css'  href='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/video-quality-selector.css' type='text/css' media='all' />
<link rel='stylesheet' id='ayvpp-style-css'  href='https://www.jupiterbroadcasting.com/wp-content/plugins//automatic-video-posts/css/style.css?ver=4.0' type='text/css' media='all' />
<link rel='stylesheet' id='radiojar-css'  href='//proxy.radiojar.com/wrappers/api-plugins/v1/css/player.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='//netdna.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Ubuntu:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/bower_components/font-awesome/css/font-awesome.min.css?ver=2018071802' type='text/css' media='all' />
<link rel='stylesheet' id='default-css'  href='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/style.css?ver=2018071802' type='text/css' media='all' />
<link rel='stylesheet' id='amazon-link-style-css'  href='https://www.jupiterbroadcasting.com/wp-content/plugins/amazon-link/Amazon.css?ver=3.2.10' type='text/css' media='all' />
<script type='text/javascript' src='//vjs.zencdn.net/4.12/video.js' id='videojs-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/scripts/video-quality-selector.js' id='video-quality-selector-js-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/scripts/videojs-seek.min.js' id='videojs-seek-js'></script>
<script type='text/javascript' src='//code.jquery.com/jquery-3.2.1.min.js' id='jquery-js'></script>
<script type='text/javascript' src='//netdna.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js' id='bootstrap-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/scripts/smooth.js?ver=2018071802' id='smooth-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/scripts/layers.js?ver=2018071802' id='layers-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/scripts/motionpack.js?ver=2018071802' id='motionpack-js'></script>
<link rel="https://api.w.org/" href="https://www.jupiterbroadcasting.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.jupiterbroadcasting.com/wp-json/wp/v2/posts/145067" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.jupiterbroadcasting.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.jupiterbroadcasting.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Linux Action News 189' href='https://www.jupiterbroadcasting.com/145052/linux-action-news-189/' />
<link rel='next' title='Google I/NO | Coder Radio 414' href='https://www.jupiterbroadcasting.com/145082/google-i-no-coder-radio-414/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://www.jupiterbroadcasting.com/?p=145067' />
<link rel="alternate" type="application/json+oembed" href="https://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jupiterbroadcasting.com%2F145067%2Fmars-goes-to-shell-linux-unplugged-406%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.jupiterbroadcasting.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jupiterbroadcasting.com%2F145067%2Fmars-goes-to-shell-linux-unplugged-406%2F&#038;format=xml" />
<!-- WALL= --><script type="text/javascript">
function limitChars(textid, limit, infodiv)
{
	var text = jQuery('#'+textid).val();	
	var textlength = text.length;
	if(textlength > limit)
	{
		jQuery('#' + infodiv).html('You cannot write more then '+limit+' characters!');
		jQuery('#'+textid).val(text.substr(0,limit));
		return false;
	}
	else
	{
		jQuery('#' + infodiv).html('You have '+ (limit - textlength) +' characters left.');
		return true;
	}
}
function displayVals() {
      var t3 = jQuery("#t3").val();
      var amount = jQuery("#amount").val();
      if(t3 != 0){
	    jQuery('#a3').val(amount);
	    jQuery('#p3').val(1);
		jQuery('#cmd').val('_xclick-subscriptions')
	  }else{
	  	jQuery('#a3').val(0);
	  	jQuery('#p3').val(0);
	  	jQuery('#cmd').val('_donations');
	  }
	  if( !t3 ) jQuery('#cmd').val('_donations');
	  
}

jQuery(function(){
 	jQuery('#donor_comment').keyup(function(){
 		limitChars('donor_comment', 199, 'charinfo');
 	})

 	jQuery("#amount").change(displayVals);
 	jQuery("#t3").change(displayVals);
 	displayVals();
 	
 	var WallOps1 = '<p class="show_onwall" id="wallops"><input type="hidden" name="item_number" value="0:0" /></p>';
 	var WallOps2 = '<p class="show_onwall" id="wallops"><label for="show_onwall">Show on Wall:</label><br /><select name="item_number"><option value="1:0">Donation Amount, User Details &amp; Comments</option><option value="2:0" selected="selected">User Details &amp; Comments Only</option></select></p>';

 	if( jQuery('#recognize').is(':checked') == false){ 
 		jQuery('#wallinfo').hide();
 		jQuery("#wallops").html(WallOps1);
 	}
 	
 	jQuery("#recognize").click(function(){
 		jQuery("#wallinfo").toggle('slow');
 		if(jQuery('#wallops input').val() == '0:0'){ 
 			jQuery("#wallops").html(WallOps2);
 		}else{
 			jQuery("#wallops").html(WallOps1);
 		}
 	})
 	
		
});

</script>
        <link rel="amphtml" href="https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/amp/"><link rel="icon" href="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/cropped-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/cropped-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/cropped-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/cropped-favicon-270x270.png" />
</head>
<body class="post-template-default single single-post postid-145067 single-format-standard">

	<div id="header">

		<div id="logo">
			<div class="wrapper">
                              <div id=headerlogo>
				<a href="https://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/logo.png" alt="Jupiter Broadcasting" /></a>
                              </div>

                        <div id=headersocialicons>
	                 <ul class='inline icons'>
			<li>
			<a target="_blank" href="https://www.youtube.com/user/jupiterbroadcasting" title="Subscribe on Youtube">
				<img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/2a2a2a-youtube.svg"/>
			</a>
		        </li>
			<li>
			<a target="_blank" href="https://twitter.com/jupitersignal" title="Follow us on Twitter">
				<img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/2a2a2a-twitter.svg"/>
			</a>
			</li>
			<li>
			<a target="_blank" href="http://www.facebook.com/pages/Jupiter-Broadcasting/156241429615" title="Join our Facebook Page">
				<img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/2a2a2a-facebook.svg" />
			</a>
			</li>
                          <li>
				<a target="_blank" href="/telegram" title="Join our Telegram Group">
				<img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/2a2a2a-telegram.svg"/>
				</a>
			</li>
			<li>
			<a target="_blank" href="https://kiwiirc.com/client/irc.geekshed.net/?nick=JBLive_?&theme=cli#jupiterbroadcasting" title="Join our IRC Room">
				<img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/2a2a2a-irc.svg" />
			</a>
			</li>
	</ul>
        </div>
			</div>
		</div>

		<div class="container">

			<nav class='navbar navbar-default' role="navigation">

				<div class="navbar-header">
					<button type='button' class='navbar-toggle' data-toggle='collapse' data-target='#main-menu'>
						<span class="sr-only">Toggle navigation</span>
						<span class="icon-bar"></span>
						<span class="icon-bar"></span>
						<span class="icon-bar"></span>
					</button>
				</div>

				
				<div id="main-menu" class="collapse navbar-collapse"><ul id="menu-main-menu" class="nav navbar-nav"><li id="menu-item-34721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-34721"><a title="Home" href="http://www.jupiterbroadcasting.com">Home</a></li>
<li id="menu-item-34726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34726 dropdown"><a title="Shows" href="#" data-toggle="dropdown" class="dropdown-toggle">Shows <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-34741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34741"><a title="Coder Radio" href="https://www.jupiterbroadcasting.com/show/coderradio/">Coder Radio</a></li>
	<li id="menu-item-134512" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134512"><a title="Jupiter EXTRAS" href="https://www.jupiterbroadcasting.com/show/extras/">Jupiter EXTRAS</a></li>
	<li id="menu-item-114676" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114676"><a title="Linux Action News" href="https://www.jupiterbroadcasting.com/show/linux-action-news/">Linux Action News</a></li>
	<li id="menu-item-41942" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-41942"><a title="LINUX Unplugged" href="https://www.jupiterbroadcasting.com/show/linuxun/">LINUX Unplugged</a></li>
	<li id="menu-item-134507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-134507"><a title="Self-Hosted" href="https://www.jupiterbroadcasting.com/show/self-hosted/">Self-Hosted</a></li>
</ul>
</li>
<li id="menu-item-130251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-130251 dropdown"><a title="Show Feeds" href="#" data-toggle="dropdown" class="dropdown-toggle">Show Feeds <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-130256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130256"><a title="All Shows Audio" href="http://feeds2.feedburner.com/JupiterBroadcasting">All Shows Audio</a></li>
	<li id="menu-item-130261" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130261"><a title="All Shows Video" href="http://feeds2.feedburner.com/AllJupiterVideos">All Shows Video</a></li>
	<li id="menu-item-142752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142752"><a title="Coder Radio" href="http://coder.show/rss">Coder Radio</a></li>
	<li id="menu-item-134517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-134517"><a title="Jupiter EXTRAS" href="https://extras.show/rss">Jupiter EXTRAS</a></li>
	<li id="menu-item-130281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130281"><a title="Linux Action News" href="http://linuxactionnews.com/rss">Linux Action News</a></li>
	<li id="menu-item-130286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130286"><a title="LINUX Unplugged" href="https://linuxunplugged.com/rss">LINUX Unplugged</a></li>
	<li id="menu-item-130966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130966"><a title="Self-Hosted" href="https://selfhosted.show/rss">Self-Hosted</a></li>
</ul>
</li>
<li id="menu-item-34796" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34796"><a title="LIVE!" href="https://www.jupiterbroadcasting.com/watch-us-live/">LIVE!</a></li>
<li id="menu-item-34801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34801"><a title="Calendar" href="https://www.jupiterbroadcasting.com/release-calendar/">Calendar</a></li>
<li id="menu-item-34806" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34806"><a title="Contact" href="https://www.jupiterbroadcasting.com/contact/">Contact</a></li>
<li id="menu-item-49972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49972 dropdown"><a title="Archive" href="#" data-toggle="dropdown" class="dropdown-toggle">Archive <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-113496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113496"><a title="Ask Noah" href="https://www.jupiterbroadcasting.com/show/asknoah/">Ask Noah</a></li>
	<li id="menu-item-49982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49982"><a title="Beer is Tasty" href="https://www.jupiterbroadcasting.com/show/beeristasty/">Beer is Tasty</a></li>
	<li id="menu-item-42722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42722"><a title="BSD Now" href="https://www.jupiterbroadcasting.com/show/bsdnow/">BSD Now</a></li>
	<li id="menu-item-129131" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-129131"><a title="Choose Linux" href="https://www.jupiterbroadcasting.com/show/choose/">Choose Linux</a></li>
	<li id="menu-item-49997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49997"><a title="Computer Action Show" href="https://www.jupiterbroadcasting.com/show/cas/">Computer Action Show</a></li>
	<li id="menu-item-34746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34746"><a title="FauxShow" href="https://www.jupiterbroadcasting.com/show/fauxshow/">FauxShow</a></li>
	<li id="menu-item-130971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-130971"><a title="Friday" href="https://www.jupiterbroadcasting.com/show/friday/">Friday</a></li>
	<li id="menu-item-59332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59332"><a title="HowTo Linux" href="https://www.jupiterbroadcasting.com/show/h2l/">HowTo Linux</a></li>
	<li id="menu-item-50007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50007"><a title="IN DEPTH LOOK" href="https://www.jupiterbroadcasting.com/show/indepthlook/">IN DEPTH LOOK</a></li>
	<li id="menu-item-50037" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50037"><a title="Joint Failures" href="https://www.jupiterbroadcasting.com/show/jointfailures/">Joint Failures</a></li>
	<li id="menu-item-50012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50012"><a title="Jupiter@Nite" href="https://www.jupiterbroadcasting.com/show/nite/">Jupiter@Nite</a></li>
	<li id="menu-item-50042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50042"><a title="Legend of the Stoned Owl" href="https://www.jupiterbroadcasting.com/show/legend-of-the-stoned-owl/">Legend of the Stoned Owl</a></li>
	<li id="menu-item-34766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34766"><a title="Linux Action Show" href="https://www.jupiterbroadcasting.com/show/linuxactionshow/">Linux Action Show</a></li>
	<li id="menu-item-50017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50017"><a title="MMOrgue" href="https://www.jupiterbroadcasting.com/show/mmorgue/">MMOrgue</a></li>
	<li id="menu-item-35751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35751"><a title="Plan B" href="https://www.jupiterbroadcasting.com/show/planb/">Plan B</a></li>
	<li id="menu-item-88001" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88001"><a title="Rover Log" href="https://www.jupiterbroadcasting.com/show/rover-log/">Rover Log</a></li>
	<li id="menu-item-34771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34771"><a title="SciByte" href="https://www.jupiterbroadcasting.com/show/scibyte/">SciByte</a></li>
	<li id="menu-item-50022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50022"><a title="STOked" href="https://www.jupiterbroadcasting.com/show/stoked/">STOked</a></li>
	<li id="menu-item-58772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58772"><a title="Tech Talk Today" href="https://www.jupiterbroadcasting.com/show/today/">Tech Talk Today</a></li>
	<li id="menu-item-34781" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34781"><a title="TechSNAP" href="https://www.jupiterbroadcasting.com/show/techsnap/">TechSNAP</a></li>
	<li id="menu-item-50027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50027"><a title="TORked" href="https://www.jupiterbroadcasting.com/show/torked/">TORked</a></li>
	<li id="menu-item-34786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34786"><a title="Unfilter" href="https://www.jupiterbroadcasting.com/show/unfilter/">Unfilter</a></li>
	<li id="menu-item-102376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102376"><a title="User Error" href="https://www.jupiterbroadcasting.com/show/error/">User Error</a></li>
	<li id="menu-item-71892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-71892"><a title="Women&#039;s Tech Radio" href="https://www.jupiterbroadcasting.com/show/wtr/">Women&#8217;s Tech Radio</a></li>
</ul>
</li>
</ul></div>
				<form method="get" id="searchForm" action="https://www.jupiterbroadcasting.com/" class='navbar-form navbar-right hidden-sm'>
	<input placeholder="Search..." name="s" id="s" value="" />
	<input id="searchsubmit" type="image" src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/search.png" alt="Submit" />
</form>

			</nav>

			
		</div>

	</div>

			
			<div id="thevideo">
				<div id="thevideoinside">
					<div id="videoembed" class='container'>
											<div class='video responsive-object-wrapper'><iframe width="560" height="315" src="https://www.youtube.com/embed/FJBo2GAMszE" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>										</div>
				</div>
			</div>

			<div id="content" class='container'>
				<div class='row'>
					<div id="contentleft" class='col-md-8 col-lg-9'>
						<div id="">
							<div id="videodets" class='clearfix'>
								<div id="postinfo">
									<h2><a href="https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" title="Mars Goes to Shell | LINUX Unplugged 406">Mars Goes to Shell | LINUX Unplugged 406</a></h2>
									<p class="itemlinks"></p>
									<p class="itemlinks">Posted on: <a href="https://www.jupiterbroadcasting.com/date/2021/05/21/">May 18, 2021</a></p>
									<p class="itemlinks">Posted in: <a href="https://www.jupiterbroadcasting.com/show/featured/" rel="category tag">Featured</a>, <a href="https://www.jupiterbroadcasting.com/show/linuxun/" rel="category tag">LINUX Unplugged</a>, <a href="https://www.jupiterbroadcasting.com/show/video/" rel="category tag">Video</a></p>
									<p class="itemlinks"><a href="#comments" title="Comment on This Video">Comment on This Video</a></p>
									<p class="itemlinks"><a href="javascript:;" onmousedown="toggleSlide('sharearea');" title="Share this episode with others">Share This Video</a></p>

									<div id="sharearea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0; ">
									<div id="socialize">
										<div style="float: left; width:150px;">
											<ul style="list-style-type: none; line-height: 20px; padding-top: 5px;">
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/delicious.gif" alt="del" /> <a href="http://del.icio.us/post?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">del.icio.us</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/blinklist.gif" alt="blink" /> <a href="http://blinklist.com/index.php?Action=Blink/addblink.php&Url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">blinklist</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/digg.gif" alt="digg" /> <a href="http://digg.com/submit?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">digg</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/facebook.gif" alt="face" /> <a href="http://www.facebook.com/share.php?u=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Facebook</a></li>
											</ul>
										</div>

										<div style="float: left; width:150px;">
											<ul style="list-style-type: none; line-height: 20px; padding-top: 5px;">
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/furl.gif" alt="furl" /> <a href="http://furl.net/storeIt.jsp?u=&t=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Furl</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/magnolia.gif" alt="magnol" /> <a href="http://ma.gnolia.com/bookmarklet/add?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">ma.gnolia</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/newsvine.gif" alt="newsv" /> <a href="http://www.newsvine.com/_wine/save?u=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Newsvine</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/pownce.gif" alt="pownce" /> <a href="http://pownce.com/send/link/?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Pownce</a></li>
											</ul>
										</div>

										<div style="float: left; width:150px;">
											<ul style="list-style-type: none; line-height: 20px; padding-top: 5px;">
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/reddit.gif" alt="reddit" /> <a href="http://reddit.com/submit?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">reddit</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/stumbleupon.gif" alt="stumble" /> <a href="http://www.stumbleupon.com/submit?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">StumbleUpon</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/technorati.gif" alt="tech" /> <a href="http://www.technorati.com/faves?add=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Technorati</a></li>
												<li><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/share/twitter.gif" alt="twit" /> <a href="http://twitthis.com/twit?url=https://www.jupiterbroadcasting.com/145067/mars-goes-to-shell-linux-unplugged-406/" target="_blank">Twitter</a></li>
											</ul>
										</div>
									</div>
									</div>

									<p class="itemlinks"><a href="javascript:;" onmousedown="toggleSlide('embedarea');" title="Embed episode on your website">Embed This Video</a></p>

									<div id="embedarea" style="display:none; width:640px; float:left; height:100px; padding:0 0 10px 0;">
										<textarea name="thoughts" rows=4 style="border:1px solid #B8B8B8; width:642px; background:none; padding:5px; color:#565050; font-family:Arial, Helvetica, sans-serif; font-size: 12px; margin-top: 10px; overflow: hidden;"><div class='video responsive-object-wrapper'><iframe width="560" height="315" src="https://www.youtube.com/embed/FJBo2GAMszE" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></textarea>
									</div>
								</div>

								<div class="thumbnail">
																			<img width="300" height="168" src="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658-300x168.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658-300x168.png 300w, https://www.jupiterbroadcasting.com/wp-content/uploads/2019/04/WP-LUP-350x196-0419-e1600641753658.png 729w" sizes="(max-width: 300px) 100vw, 300px" />																	</div>
							</div>

															<div id="synopsis">
									<p>Tim Canham, Mars Helicopter Operations Lead at NASA&#8217;s JPL joins us again to share technical details you&#8217;ve never heard about the Ingenuity Linux Copter on Mars. And the challenges they had to work around to achieve their five successful flights.</p>
								</div>
							
							
															<div id="direct-downloads">
									<h3>Direct Download:</h3>
									<ul>
																																<li><a href="http://www.podtrac.com/pts/redirect.mp3/chtbl.com/track/392D9/aphid.fireside.fm/d/1437767933/f31a453c-fa15-491f-8618-3f71f1d565e5/f765fe5d-7c43-4771-8213-c2e664c2430d.mp3">MP3 Audio</a></li>
																																<li><a href="http://www.podtrac.com/pts/redirect.mp4/201406.jb-dl.cdn.scaleengine.net/linuxun/2021/lup-0406.mp4">Video</a></li>
																																<li><a href="https://youtu.be/FJBo2GAMszE">YouTube</a></li>
																			</ul>
								</div>
							
							<div id="postcontent">
								<h3><a href="https://linuxunplugged.com/406">Show Notes: linuxunplugged.com/406</a></h3>
							</div>

							
															<h3>Question? Comments? <a href="/contact">Contact us here!</a></h3>
													</div>
					</div>

					<div id="contentright" class='col-md-4 col-lg-3'>
						<div id="sidebar">

	<div id="logo" class='hidden-md hidden-lg'>
	<a href="https://www.jupiterbroadcasting.com/" title="Jupiter Broadcasting"><img src="https://www.jupiterbroadcasting.com/wp-content/themes/jb2019-butterfly-2.3/images/logo.png" alt="Jupiter Broadcasting" /></a>
</div>

	
	
</div>					</div>
				</div>
			</div>

			

<div id="footer-spacer"></div>
<div id="footer">
	<div class="container">

		
		<div class="licensecopy">

			<p class="license">Our shows are licensed under <a href="http://creativecommons.org/licenses/by-sa/4.0/"><strong>Creative Commons BY-SA 4.0</strong></a></p>
		</div>

	</div>
</div>

<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-content/plugins//automatic-video-posts/js/scripts.js?ver=1.0' id='ayvpp-scripts-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jstimezonedetect/1.0.4/jstz.min.js?ver=2018071802' id='jstimezonedetect-js'></script>
<script type='text/javascript' src='https://www.jupiterbroadcasting.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>

<script>
jQuery(function($){
	$('#contentleft').on('click', '.loadmore', function(e) {
		e.preventDefault();
		var $this = $(this);
		if (!$this.hasClass('loading')) {
			$this.addClass('loading');
			$this.html('<i class="fa fa-fw fa-spinner fa-spin"></i> Loading...');
			$.get(this.href).done(function(response) {
				$(response).find('.videoitem').appendTo('#videogallery');
				$this.replaceWith( $(response).find('.loadmore').get(0) );
			});
		}
	});
});


(function($) {
	var calendarBase = "//www.google.com/calendar/embed?showTitle=0&showNav=0&showPrint=0&showTabs=0&showCalendars=0&mode=AGENDA&wkst=1&bgcolor=%23FFFFFF&src=jalb5frk4cunnaedbfemuqbhv4%40group.calendar.google.com&color=%235229A3"
	var tz = jstz.determine();
	var tzname = encodeURIComponent(tz.name());

	$('.calendar-container').find('iframe').attr('src', calendarBase + "&ctz=" + tzname);

	$('select[name=ctz]').on('change', function() {
		var $this = $(this);
		$this.closest('.calendar-container').find('iframe').attr('src', calendarBase + "&ctz=" + $this.val());
	});
})(jQuery);

</script>


<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/


Served from: www.jupiterbroadcasting.com @ 2021-05-21 02:37:44 by W3 Total Cache
-->